SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
I've been having trouble getting my R to start the past couple days. Turn the key in the ignition and it doesn't crank at all. I hear no starter clicking. Eventually (anywhere for a minute to 15) the starter turns over and the car starts right up. Today after attempting to start the car for ~10 mins I saw an immobilizer error display but only once. It seems like the longer the car has been sitting the more likely it is to start right up.

I've tried all 3 of my keys (2 masters and a valet) and it doesn't appear to make any difference. I've also tried replacing the batteries in the master keys

This weekend I'm going to try to clean off any corrosion that might have built up on the starter wires and see if that solves the problem.

Any other suggestions on things to check? (immobilizer antena ring?) Anyone else have this problem
 

·
Registered
Joined
·
1,341 Posts
Make sure the power connections to the starter are making good contact. Mothers xc70 did the same thing and the female slide connector was deformed and wasn't making good contact.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #3
yes I was going to check the starter connections this weekend. Seemed like a good starting place

Can anyone confirm whether or not the car will turn over if its having immobilizer issues? I found a few places that seem to say the immobilizer only cuts spark and the the starter should still kick over in the event of immobilizer problems.
 
1 - 3 of 3 Posts
Top