SwedeSpeed - Volvo Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter · #1 ·
My g/f has a P1 S40 that has developed a strange hissing/rubbing/squealing noise upon accelerating. It sounds like it's coming from the wheels (more than one at the same time...?). It's not loud but it is disconcerting.<p>It sounds like the pads might be low, but like I said, it's only when accelerating. If the car is coasting or the brakes are applied the noise disappears. I've read some things about the driveshaft rubbing the exhaust but I figured that wouldn't apply to a FWD...<p>Any thoughts?<br>
 

·
Registered
Joined
·
4,638 Posts
Its the rear brake pads that have to be changed....I have a P2 S40 and thats the noise telling you that the rear pads are low and need to be changed....There isn't a sensor on the rear pads like the front brake pads on the 40s....so you have to listen for a noise from the brakes or check the pads regularly.
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #3 ·
Ok, well I think the car is going to the dealer for service this week so hopefully this will be fixed. I'm just hoping it won't need rotors at the same time...
 

·
Registered
Joined
·
135 Posts
Discussion Starter · #4 ·
For anybody's reference in the future:<p>The rear pads were indeed gone, that was most likely the source of the noise. Unfortunately the rotors were very worn and needed replacement at all 4 corners (!!). <p>So $900 later, no more noise.
 

·
Registered
Joined
·
4,638 Posts
Re: (Crashy)

I knew that it was the rear pads <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> b/c it happened to me, but I was lucky that my rotors were alright. That sux man!
 
1 - 5 of 5 Posts
Top