SwedeSpeed - Volvo Performance Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 · (Edited)
I do have premium Spotify, so wondering if it won't connect to Pandora or Tune In as I don't have premium.

Oddly, both will sign in, and show all of my info, playlists and library - but won't "connect" and play music. (I have deleted and re-installed both apps).

Don't think it has anything to do w/AT&T subscription, Dealer told me to stream off my phone - that's not an answer for why Spotify works just fine and the others don't.

***ON EDIT - I have confirmed this was corrected by subscribing to the AT&T in car modem*****
 

·
Registered
Joined
·
80 Posts
I have free TuneIn account (for some foreign radio stations) and it streams just fine. Also in Seattle. Premium Spotify works as well, of course. Never tried Pandora, don't even have it installed.
 

·
VOC / Connectivity Expert
Joined
·
650 Posts
I do have premium Spotify, so wondering if it won't connect to Pandora or Tune In as I don't have premium.

Oddly, both will sign in, and show all of my info, playlists and library - but won't "connect" and play music. (I have deleted and re-installed both apps).

Don't think it has anything to do w/AT&T subscription, Dealer told me to stream off my phone - that's not an answer for why Spotify works just fine and the others don't.
You need an ATT data plan for wifi, Pandora and TuneIn.

Just activate your 3 month trial if you have it.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #4 · (Edited)
WhoaVolvo - don't think that's the issue, because Spotify works just fine.
And it loads the playlists and library for both Pandora and Tunin.. just won't play music.
 

·
VOC / Connectivity Expert
Joined
·
650 Posts
WhoaVolvo - don't think that's the issue, because Spotify works just fine.
And it loads the playlists and library for both Pandora and Tunin.. just won't play music.
I'm telling you. That's the issue 🙂

Specifically there is some loophole regarding Spotify, admittedly. But, the listing of streams on the other apps is "free" while playing the stream is paid-for data. It's a crummy implementation, but truth.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #8 ·
Yes - Once I reactivated the ATT subscription, everything started working. Still doesn't explain why Spotify works regardless of the subscription though.
 

·
Registered
Joined
·
22 Posts
I do have premium Spotify, so wondering if it won't connect to Pandora or Tune In as I don't have premium.

Oddly, both will sign in, and show all of my info, playlists and library - but won't "connect" and play music. (I have deleted and re-installed both apps).

Don't think it has anything to do w/AT&T subscription, Dealer told me to stream off my phone - that's not an answer for why Spotify works just fine and the others don't.

***ON EDIT - I have confirmed this was corrected by subscribing to the AT&T in car modem*****
I also had this issue .. everything worked, but Pandora would stay "connecting." I figured it out: Pandora has access restrictions based on your location.

I'm in the US, but the SIM I am using for the hotspot the car (and Pandora) is connected to is from the UK .. and Pandora isn't available there. I found this out by connecting my phone to the hotspot, then tried Pandora .. it replies with "Sorry, Pandora isn't available in your country" which of course makes no sense, since I'm in the US.

In short, Pandora's geolocation service doesn't work properly 100% of the time.

.. I see you are located in Seattle .. maybe Pandora thinks you are in Canada.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #13 ·
The issue was resolved for me by re-subscribing to the ATT modem service and then everything worked. I turned the ATT service off as I just use Car Play to stream, so no need to have the modem active.
 
1 - 13 of 13 Posts
Top