SwedeSpeed - Volvo Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
It is possible that someone else may have had this problem or talked about it but I have been having horrible trouble trying to find any information about my problem.

My S40 has the premium sound system installed and some of my speakers are out. On my doors the top treble speakers work on all doors however the speakers on the bottom of the doors only work on the two front and are out on the two back doors. My center appears to be working fine however there is absolutely no base in my car. I do not know if my amp is our of if my sub is out or what the problem is. Volvo is reluctant to give me any information without first charging me a fee and I do not know where to start. I have checked my fuses under the hood and under the glove box and they are all fine.

Like i said music comes out of the speakers that i have but the quality is poor. I had thought that maybe i just had blown the speakers however, they will come on evey now and then and i will hear base in my car and then it will fade back out.

If anyone has any sugestions about what I should do where I should look or where I should start it would be greatly appreciated.

Also are there any repair manuals avalilabe for this car becasue I cannot find any online and i would rather make repairs myself if at all possible opposed to spending my life saving at the volvo dealer since I am out of warranty.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Re: (jdsr917)

Ok.. sounds simple enough Only problem with that is that i hae no idea how to do it myself and im not paying volvo to do it becasue they are rediculus.

My dads an electrican but he has no idea where the wires are lol. We dont do foreign cars normally.
Anyone have any suggestions.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
Re: (Percy311)

Thank you for the help. The only problem is that I normaly only listen to the cd, and I have changed every menu option that i could, I tinkered with the EQ levels but I have no idea what I was doing.

I guess the strangest thing about it is that every now and then say if I go over a pot hole too hard or if the weather is just right or something they will all turn on and I will have full sound and my sub. I thought it was something wrong with the wiring but I dont know about wiring anything in the car.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #13 ·
Re: (candwizzard)

I know i probably sound crazy, but i dont know much about the mechanics of the car I have been just driving it so now its finally time for me to learn. So thanks for the help
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #16 ·
Re: (Percy311)

ok so my speakers where just blown, the bass 6.5 speakers are the only ones that have stopped working in all four dors so now I have to find a comparable speaker that doesnt cost a ridiculous amount, any suggestions.

I started looking but the majority of the speakers I am finding have the tweeters in them alredy and I have a feeling that will be over kill, and it still wont have enought base.

Also i have a question the speakers I took out say 4 ohm, should the new speakers be 4 ohm or is 2 ohm possible with the premium system factory amp.

I have no sub.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top