SwedeSpeed - Volvo Performance Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
It is possible that someone else may have had this problem or talked about it but I have been having horrible trouble trying to find any information about my problem.<p>My S40 has the premium sound system installed and some of my speakers are out. On my doors the top treble speakers work on all doors however the speakers on the bottom of the doors only work on the two front and are out on the two back doors. My center appears to be working fine however there is absolutely no base in my car. I do not know if my amp is our of if my sub is out or what the problem is. Volvo is reluctant to give me any information without first charging me a fee and I do not know where to start. I have checked my fuses under the hood and under the glove box and they are all fine. <p>Like i said music comes out of the speakers that i have but the quality is poor. I had thought that maybe i just had blown the speakers however, they will come on evey now and then and i will hear base in my car and then it will fade back out. <p>If anyone has any sugestions about what I should do where I should look or where I should start it would be greatly appreciated.<p>Also are there any repair manuals avalilabe for this car becasue I cannot find any online and i would rather make repairs myself if at all possible opposed to spending my life saving at the volvo dealer since I am out of warranty.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Re: (jdsr917)

Ok.. sounds simple enough Only problem with that is that i hae no idea how to do it myself and im not paying volvo to do it becasue they are rediculus. <p>My dads an electrican but he has no idea where the wires are lol. We dont do foreign cars normally.<br>Anyone have any suggestions.
 

·
Registered
Joined
·
664 Posts
Re: Speakers (candwizzard)

All the speakers in each door come of the same Amp so if the top tweeters are working then it is the bottom speakers not the electronics that is the problem.<p>I replaced my front with a mid range priced 6" / tweeter combo. The 6" made a big difference but the tweeter was a waist of money. TheVolvo has a darn good soft dome tweeter to start with.<p>So just replace the 6" speakers with good high efficency (not high priced ) speaker and you should notice a big difference.
 

·
Registered
Joined
·
1,411 Posts
Re: Speakers (VictorVDC)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>VictorVDC</b> »</i></TD></TR><TR><TD CLASS="quote">All the speakers in each door come of the same Amp so if the top tweeters are working then it is the bottom speakers not the electronics that is the problem.<p>I replaced my front with a mid range priced 6" / tweeter combo. The 6" made a big difference but the tweeter was a waist of money. TheVolvo has a darn good soft dome tweeter to start with.<p>So just replace the 6" speakers with good high efficency (not high priced ) speaker and you should notice a big difference.</TD></TR></TABLE><p>Are all the speakers the same size for all stock sound systems?<p>I wanna replace my speakers, sounds hella ghetto if I turn it up past halfway
 

·
Registered
Joined
·
380 Posts
This may sound crazy, BUT (possibility) your speakers may not be blown:<p>Many of my clients (I sell Volvos) have complained of blown speakers in the S40s/V50s, but when the Dolby Surround is on, the rear speakers can have a crappy sounding effect...ESPECIALLY when listening to the radio.<p>Go in to your sub-menu and turn the surround either OFF or to 3-channel (preferably OFF to test) <p>Also, make sure that your EQ settings are set correctly in your sub menu
 

·
Registered
Joined
·
380 Posts
...I am almost POSITIVE that thats what it is. Doesnt really sound like a description of a blown speaker....no buzzing or popping<br>call me if you have any questions<br>Mike-402/960/4041
 

·
Registered
Joined
·
1,363 Posts
Re: (Percy311)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Percy311</b> »</i></TD></TR><TR><TD CLASS="quote">Go in to your sub-menu and turn the surround either OFF or to 3-channel (preferably OFF to test) <p>Also, make sure that your EQ settings are set correctly in your sub menu</TD></TR></TABLE><p>This is what I was going to suggest. My Surround fades in and out and gets very little bass when on the radio. Put in a CD and leave it on Surround Sound and see how it works then... <p>Check you EQ too as Percy said... <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Registered
Joined
·
542 Posts
Re: (s40boy)

My car went in yesterday for the exact same thing. Turns out all 4 door speakers are shot (porter at the dealership thought it would be great to crank my stereo). Next week the car gets re-fitted with OEMs. We set all the factory levels by reset and it appears that the rear door speakers will not turn on at all.<br>Todd
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
Re: (Percy311)

Thank you for the help. The only problem is that I normaly only listen to the cd, and I have changed every menu option that i could, I tinkered with the EQ levels but I have no idea what I was doing. <p>I guess the strangest thing about it is that every now and then say if I go over a pot hole too hard or if the weather is just right or something they will all turn on and I will have full sound and my sub. I thought it was something wrong with the wiring but I dont know about wiring anything in the car. <p>
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #13 ·
Re: (candwizzard)

I know i probably sound crazy, but i dont know much about the mechanics of the car I have been just driving it so now its finally time for me to learn. So thanks for the help <br>
 

·
Registered
Joined
·
4,024 Posts
Hmm that sound like i might have something wrong with one of the channels from the head amp ... i was told all the speakers in the premium system have something for each speaker that burns out alot but it doesnt completly stop working i had the same problem till they replaced it
 

·
Registered
Joined
·
380 Posts
...and your sub??<p>Do you have an aftermarket sub or is it all stock? (there is a factory sub OPTION, but you DONT have it unless your sound menu has a subwoofer option menu
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #16 ·
Re: (Percy311)

ok so my speakers where just blown, the bass 6.5 speakers are the only ones that have stopped working in all four dors so now I have to find a comparable speaker that doesnt cost a ridiculous amount, any suggestions. <p>I started looking but the majority of the speakers I am finding have the tweeters in them alredy and I have a feeling that will be over kill, and it still wont have enought base. <p>Also i have a question the speakers I took out say 4 ohm, should the new speakers be 4 ohm or is 2 ohm possible with the premium system factory amp.<p>I have no sub.
 
1 - 16 of 16 Posts
Top