SwedeSpeed - Volvo Performance Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
I've had my S60 for about 6 months now, and generally like it. However there are two things bothering me.

One is fairly minor - on the fourth or fifth opening (tilt) of my sunroof, one of the black plastic 'accordian' things that are on the sides split completely in half. The next time I tilted it, the other one went. Anyone experience this? I know it'll be replaced via warranty, but it's still bothersome.

The other item, which bugs me much more, is the Geartronic transmission. I have a T5, and the transmission, to put it professionally, sucks. It's sluggish, especially when cold. When pulling out from a standstill, I'll press down on the gas and get very little response - the car just drags along, then finally, I'll get a lurch of power and start moving. My wife's Corolla is more responsive in low speed maneuvers - I just can't seem to finesse it.

Worse, when I'm tooling along in the usual slow stop/go traffic, the car waffles between 4th and 5th. Feels just like my old VW bug when the clutch was going.

Maybe I'm just not used to an auto after driving nothing but stick all my life, but I expected better. Certainly don't remember these problems in the test drive.
 

·
Registered
Joined
·
20 Posts
hi,

i've had mine for about two weeks, i can't comment on the sunroof. but i can relate to the acceleration...i've just attributed that to turbo lag and the fact it's an inline 5. i got rid of my ford lightning with 440 lbs of torque, so the volvo isnt going to compare. i'm waiting for a performance filter as this may solve some of the problems. but this is my first volvo, so my input is limited...

tom
 
1 - 2 of 2 Posts
Top