SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
Slight oil like dust on back bumper? Anyone else have this?

i never see smoke but after a few days of harder than normal driving i notice some slight oil like dust on the back bumper and the license plate. I see no soot in the tail pipe and there is no oil in the inter cooler hoses or pipes

S70 T5 AT
 

·
Registered
Joined
·
6,571 Posts
Sound like oil being burned either from valve stem seals or in the turbocharger.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #4 ·
Sound like oil being burned either from valve stem seals or in the turbocharger.
That is what i thought but there is no oil in the inter cooler and i dont see any smoke at start up or when hitting boost.



when my rear main seal was failing i noticed oil film on the back of the car all the time
Mine needs to be replaced ASAP
 

·
Registered
Joined
·
6,571 Posts
That is what i thought but there is no oil in the inter cooler and i dont see any smoke at start up or when hitting boost.



Mine needs to be replaced ASAP
That's interesting. Maybe it's on the exhaust side? Cost down a long hill and see if it smokes after coasting when you hit the gas.
 

·
Registered
Joined
·
7,612 Posts
Generally any oil leaks that happen while driving always blow up on the back surface of a car.
 

·
Registered
Joined
·
5,980 Posts
This happened to me when my intake cam seal blew. It could be any of your seals though.
 

·
Registered
Joined
·
271 Posts
Here's your original post, and the answer is right there


I just picked up a 1998 S70 T5, Its an auto with 143K miles, it was cheap, $800.

Needs RMS replaced. I got a price of $850 to do that. Sounds fair to me. Dude said if i bring him new axles he will do them too. I figured as much because the old ones have to come out any way. Im just thinking it over because if he has the tranny out why not just replace it with a rebuilt or better used one. Not that mine is bad but who knows. He gave me some ideas of what it would cost and it did not seem that scary at all. PCV system checks out fine so i guess the RMS is just from age.

The exhaust sounded horrid but i had a local buddy (The Muffler Man) cut and bent some pipe and welded new from the cat to the center muffler then a new pipe from there out the back, the back muffler was gone. $200 so now im up to $1K In total for the car

Boost hits good but i feel the slightest flutters, just slight.

One thing to day tho, i just replaced the heater core with a cheap bozo 3rd world on and man did i make a mistake. The stink when i turn the heat on is very VERY bad. It had the smell of industrial chemicals and fire. I just hope it burns off soon. It hurts my throat and lungs.

Other than that, the interior is MINT, no rust, a small dent. Everything works great, sun roof, power seats, heated seats and windows all work as the should. Glad no one smoked in the. Im happy with this cheap ride. Ill do the timing belt in the spring, it was last done at 89K
 

·
Registered
Joined
·
637 Posts
Yeah, that's from the RMS. Leaky cam seals and oil cooler hoses will cause that too.
 
1 - 9 of 9 Posts
Top