SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
274 Posts
Discussion Starter · #1 ·
My 05 V50 T5 auto (74K miles) is acting a bit strange of late. On short around town trips and out on the highway it runs real well, the turbo spools, it downshifts and launches, it runs up to (speeding) speed real nicely, all normal.<br>After a two or so hour trip it seems to lose power....? It seems like I need to have the pedal all the way to the floor, it bogs down, it crawls up hills, it does not excite or impress.<p>I don't understand. Fuel filter? I have never changed it and bought it used. <p>Other ideas please"? My old GLT has more punch that the V50 of late.
 

·
Registered
Joined
·
7,288 Posts
I believe the fuel filter on the 05's is internal, thus meaning no real replacement option...correct me if I'm wrong Kyle!
 

·
Registered
Joined
·
8,379 Posts
Re: Sleepy V50 (mgc)

1. How Many Miles are On Plugs ?<p>Get some Good Plugs !<p><br>2. Have Your Ever Cleaned Out the Cooling system as It Is Really Due<p> 4 Yrs. Have It Done Right and make sure - Good Stuff goes back In .<p><br>Three have You Done anything to Allow the Car to Run Cooler ?<p>Like Behind the Grill Silencer - Removal ? 1 Step Cooler Plugs ?<p>Where have You Been Buying Your Fuel ? I Know they say Don't or Not Needed ,but a Good Fuel Line - Injector Cleaner with Octane Booster.<br>Just ,Before You Change the Oil . ( Should Kick It Up ) <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <p><br>Besides the above , I have also Opened Up the Splash Shield Vents in a Manner that will Allow for Air Flow - Thur - Engine Compartment . I have also Backed Off the Air Horn about .8750 so It's Not Stressing as Much to Suck the Air and It's most likely not Pulling<br>as many BTU's Off the Ecu ( Small Amount ) . <p>So You Add up all the Little Tweaks , and Cooler & Easier Running Motor - so I don't Suffer to much at 70 Degrees with the Air On .<p>Also Is Your Volvo an Automatic ?
 

·
Registered
Joined
·
274 Posts
Discussion Starter · #5 ·
Re: Sleepy V50 (EngTech)

It is an automatic. <br>The plugs have 12,000 miles on them. <br>I have been buying fuel where ever....<br>I have not run Techron though recently.<br>I have a K&N air filter on it. <br>I have not done anything to alter the stock air flow aside from the K&N.<p>Is there a changeable fuel filter?
 

·
Registered
Joined
·
274 Posts
Discussion Starter · #6 ·
I just had the Turbo Control Valve replaced. End of problem. The TCV had a crack in it.
Interestingly the problem was very random until recently when it completely failed.
The car never threw a CEL.
 

·
Registered
Joined
·
1,360 Posts
This always seems to be the 'mystery' problem for many, many S40/V50 owners. I got fed-up of that sh!tty OEM unit and replaced it with the heavy-duty one from iPd.
 

·
Registered
Joined
·
1,761 Posts
If you have no power going up a hill, you are losing boost somewhere, and it's probably compounded by other things that also need attention.
Start with the easy stuff first:
1) clean MAF sensor could be contaminated by an overoiled K&N fillter
2) clean throttle body
3) plugs could be incorrect, no tune OEM are best
4) check all vacuum hoses, replace old and suspect
5) CBV and TCV replacing them won't make your car run better, unless they are bad, if they are cracked, it will make a big difference.
6) Check MAP sensor, make sure it is connected properly to wiring loom, & in correct position
7)Coil paks, does your car misfire when running poorly?
8) These cars are very reliable as long as they are not neglected, pro active maintenance is a very good thing.
Hope this helps and hope you get it figured out. Cheers.
 
1 - 8 of 8 Posts
Top