SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Hello R fans more knowledgable than me. I got packs changed 6 months ago
Along with plugs, need new motor mounts badly and was wondering if that
Might have to do with it but it still doesn't make sense. My gas mileage is down
Because I need a new o2 sensor but I don't think it would effect the car like this.
I'll switch into a gear and slam on the gas and nothing happens or I get a kick
Back from the car. It's a 2006 s60r with 134000 on it and has had the engine light
On for some time. I figured it was the o2 sensor because the mileage was only around
16 but all the sudden this starts happening. I bought the car at 116000 for 10000.
I think that's about the worst time to buy an R just for some advice people
Because the struts go and I've put about 3 grand into anyway but regardless
This was unexpected and is confusing because it's a serious kick but drives fine at
Lower revs.

MUCH appreciated people,
Marshall
 

·
Registered
Joined
·
2,045 Posts
Scan with vida. Only way to know
 

·
Registered
Joined
·
96 Posts
My one was doing this when I had the tuned chip in it. I removed it and put the standard chip in and has been fine since. The chip was not faulty, it's just that a tuned chip will exaggerate a problem. I'm not sure what was wrong with mine but I did have a leak on the inter cooler but I have not had the tuned chip back on since replacing it to see if it is any better. Sorry I can't be any more help.

Ben
 

·
Registered
Joined
·
782 Posts
1 - 4 of 4 Posts
Top