SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi i have a V70 R awd 04 man

it misfires or shakes at load it's always when I feel when the boost came it shakes as if it misfires at 3000 rpm and more clearly and more often at 5000 rpm
Just a few quick misses and then revert back to normal

fuel pressure sensor is changed, and so the filter I currently have NGK plug in the car, bought new volvo original instead but the doc has not changed them yet because my plugs has about 20000 km what

could this be the ignition coils / plugs / mass air flow sensor /solenoid valve

or is it a vaccum leak??

I can not understand this and ask humbly for your help
 

·
Registered
Joined
·
233 Posts
My first guess would be a coil. That's where I would start.
 

·
Registered
Joined
·
167 Posts
hi i have a V70 R awd 04 man

it misfires or shakes at load it's always when I feel when the boost came it shakes as if it misfires at 3000 rpm and more clearly and more often at 5000 rpm
Just a few quick misses and then revert back to normal

fuel pressure sensor is changed, and so the filter I currently have NGK plug in the car, bought new volvo original instead but the doc has not changed them yet because my plugs has about 20000 km what

could this be the ignition coils / plugs / mass air flow sensor /solenoid valve

or is it a vaccum leak??

I can not understand this and ask humbly for your help
Could be a leak in one of the intercoolers or airleak somewhere at the intakeside!Any faultcodes!?
 

·
Super Moderator
Joined
·
14,824 Posts
Fault coils is my guess as well.
 

·
Registered
Joined
·
3,445 Posts
I think coils to. I got a set of stock coils out of my 05 R with 47 k on them. If you want to buy them.
 

·
Registered
Joined
·
11,628 Posts
Get your codes read first to see which cylinder is misfiring. To verify its the coils you can move them around to see if the misfire follows the suspected coil pack. If so replace coils. Note, Cylinder 1 is closest to the timing belt.

I would also check for any boost leaks as well as they can cause stuttering too.
 

·
Registered
Joined
·
209 Posts
I have the same issue. It only happens when I hit 15 psi. I can't figure out what the issue is my self. I was thinking tcv or wastgate?
 

·
Registered
Joined
·
343 Posts
Buddy had a thread going a lil while back same symptoms of Zas1, it turned out to be coils. New coils, swapped maf's, monitored fuel psi with scangauge all were fine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
I have no trouble codes so it's hard to find
what is wrong ...

does anyone know how to test coils or should we just guess
or how to find but with no error codes

I previously had a coil that died and I moved on from
cylinder 3 to 2 and moved the error to the cylinder 2 so it was changed immediately
it was easy when you can see the error codes

but when you are just guessing and pours money into the car ... I do not like

I can safely borrow a bunch of coils at a junkyard if I ask nicely :)

If I understood correctly, we have the same coils as many other
volvo and ford turbo cars 8677837 or 0221604010

so they're not unique in any way

then thinking about it the oxå on ordering from IPD HD coils
but the duty and VAT and freight will be
fairly expensive

and those who sell IPD stuff in Sweden takes terrible prices

Sincerely,
fredrik
 

·
Registered
Joined
·
745 Posts
I would put those new plugs in first. Double check that they are the correct ones. Check that the ones you take out are the correct ones. Wouldn't be the first time the wrong plugs were put in an R.
 

·
Registered
Joined
·
2,192 Posts
Plugs, make sure you gap them properly, this kind of issue pops up usually when someone has installed new plugs within a few months (but sometimes longer) and didn't gap the old plugs properly.
 

·
Registered
Joined
·
34 Posts
I am having the same problem and thought it was the coil as well. changed it out with an MSD and that was not the issue. Now I am pretty positive its my CBV diaphram.
 

·
Registered
Joined
·
209 Posts
Buddy had a thread going a lil while back same symptoms of Zas1, it turned out to be coils. New coils, swapped maf's, monitored fuel psi with scangauge all were fine.
Thanks for the advice. New coils are so expensive. Anyone have a good st I can buy at a low cost or know where to find some without me paying an arm and leg? Thanks
 

·
Registered
Joined
·
1,028 Posts
Plugs, make sure you gap them properly, this kind of issue pops up usually when someone has installed new plugs within a few months (but sometimes longer) and didn't gap the old plugs properly.
Agreed. Didn't check gaps and had this exact issue. Pulled them out and they were all over the map, from .035 to .050. Really bad.
 

·
Registered
Joined
·
528 Posts
Thanks for the advice. New coils are so expensive. Anyone have a good st I can buy at a low cost or know where to find some without me paying an arm and leg? Thanks
I have a full set of stock R coils for sale, just haven't put them in the classifieds yet. PM me if you're interested.
 

·
Registered
Joined
·
5,054 Posts
This issue goes back a long ways. It can be a number of things. You need to start at the beginning and clean the MAF. The next step is TCV and that solved my problem. Then continue on down the line with sensors. It gets frustrating, but you don't want to just start throwing parts at it. There was a logical progression to follow that should be archived.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #18
yes it was as many of you thought

car company I bought the car of had the same problem they changed
the spark plugs / fuel filter / fuel pressure sensor and changed the software, etc. etc.
and the car worked fine for about 7 months

then began to miss ignition, etc.

I bought volvo original spark plugs :)
now operates car again


fun for now let's see what bsr stage 2 do with the car

Sincerely, fredde
 

·
Registered
Joined
·
8,055 Posts
It was actually the coils, but larger gaps will cause the worse coils to short first. Putting in new plugs is just a temp repair since the bad coil is still there waiting to fail again when the gap increases or the coil gets worse.
 
1 - 20 of 21 Posts
Top