SwedeSpeed - Volvo Performance Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
I'm trying to figure out why my vr is stuck at 7psi - I tried testing for boost leaks and couldn't find any. So I'm replacing all my lines with silicone lines right now.

I thought I'd try and adjust my wastegate... I pressurize the line, and the wastegate moves at around 7psi. If I clamp the line and cut off the air source, the wastegate immediately returns to the closed position. Is this normal? Or should the wastegate be able to hold pressure without bleeding it off?
 

·
Registered
Joined
·
91 Posts
Hi all wastegates should hold pressure , also have a good look at the intercooler, but do change the wastegate,
Dave
 

·
Registered
Joined
·
1,587 Posts
I think you didn’t clamp it enough and it simply leaked through the hose.
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #4 ·
I think you didn't clamp it enough and it simply leaked through the hose.
nah man I used hose clamp pliers
Reading around the internet it seems some people are saying a little loss is normal, others are saying it definitely should hold and stay open. If someone could say definitively or test on their R I would be hugely grateful.
 

·
Registered
Joined
·
1,587 Posts
I highly recommend against Forge actuator. I bought out of curiosity. I had three units in total being sent, they all leaked.
Just a very poorly designed piece.
 

·
Registered
Joined
·
1,587 Posts
If you can find someone selling the stock K24 actuator that would be easiest. You must set the preload correctly after installing.
I used a Mamba actuator on my personal car with different spring. This is not something that works out of the box as far as the calibration goes. A lot of things have to be retuned in software.
 
1 - 11 of 11 Posts
Top