SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
655 Posts
Discussion Starter · #1 ·
This evening, shortly after I started to drive my 2018 V90, I attempted to use the Nav without success. While the Nav showed what street I was on, it would not let me enter a destination. Instead it would go into a loop trying to load a profile (which I have never set since I am the only driver) and then attempt to open the owners manual. Their loop would repeat several times. I pulled to the side of the road, turned the car off, and opened the door. When I restarted the car, there was no change and Sensus continued to “misbehave” as it had. After a while of driving, the system came back to the Home Screen, but nothing functioned. I could press any where on the screen and nothing would happen. I had no functionality with anything controlled by Sensus (including the HVAC). Eventually, after several minutes of driving, I all of a sudden had the Nav map appear and the touch screen started working normally.

What is going on? I have never had a glitch to this extent - especially where a reboot of the system did not fix it.
 

·
Registered
Joined
·
850 Posts
I would go to the dealer and let them update the soft. They do that free if there is sensus issue reported.
 

·
Registered
Joined
·
378 Posts
This evening, shortly after I started to drive my 2018 V90, I attempted to use the Nav without success. While the Nav showed what street I was on, it would not let me enter a destination. Instead it would go into a loop trying to load a profile (which I have never set since I am the only driver) and then attempt to open the owners manual. Their loop would repeat several times. I pulled to the side of the road, turned the car off, and opened the door. When I restarted the car, there was no change and Sensus continued to “misbehave” as it had. After a while of driving, the system came back to the Home Screen, but nothing functioned. I could press any where on the screen and nothing would happen. I had no functionality with anything controlled by Sensus (including the HVAC). Eventually, after several minutes of driving, I all of a sudden had the Nav map appear and the touch screen started working normally.

What is going on? I have never had a glitch to this extent - especially where a reboot of the system did not fix it.
Have you done a map update recently? Sometimes it seems to take awhile for the update processing to finish which slows the overall function.
 

·
Registered
Joined
·
655 Posts
Discussion Starter · #4 ·
The map update was about 2-3 weeks ago.
 

·
Registered
Joined
·
655 Posts
Discussion Starter · #5 ·
I would go to the dealer and let them update the soft. They do that free if there is sensus issue reported.
Appointment made. I was going to do that. Was just trying to figure out if I have a unicorn issue.
 
1 - 5 of 5 Posts
Top