SwedeSpeed - Volvo Performance Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I've had my R for a while (90k) miles 6 spd MT Not stock , yet not super modded.

some accumulative work done to the car: Snabb Intake , evolve Tune, Ipd Ignition Coils, Downpipe, Exhaust , FMIC, , CBV ,



Heres the deal: It has happened on and off - but with enough time in between each time it happens. Never freaked out about it since its probably an easy fix. But want to know what is going on?

It just happened again today (this is the 2nd or 3rd time here)
I was at the same intersection waiting to make a right, from a stop,
and when it was clear i took off in a bit of a hurry (but no spin or crazy launch or what not)
and right before it got straightened i went to put it in 2nd gear , then when i went to accelerate --there was NOTHING !
Car did not move (like it was off).. didnt revv up or anything?!? .
So i got it out of gear, revved it up a bit, and then clutch, and second gear again- and went normal from there.

It has also happened on other occasions, and i thought it was because it was lower on gas.. but this time it was 85% Full.. So, what gives?

Here is a pic of the exact intersection

[random funny thing. Somehow google maps street view took a pic of my caR when this happened Very strange coincedence ?!?!! ]





Can someone please give me any input/ ideas as to what is going on ?!

CEL came on for P0134 02 Sensor Circuit No Activity Detected (Bank I Sensor 1) - would this affect it ?

THANKS in advance
 

·
Registered
Joined
·
796 Posts
is that really your car or another S60? that's crazy if it's yours!

The only time i had issues with right hand turns was after I had my fuel pump replaced under recall and they botched the install. The pickup tube for the driver side of the tank was not firmly snapped to the bottom of the tank so it was not picking up fuel from the driver side of the tank as well. Does it occur turning left? going straight from a stop?
 

·
Registered
Joined
·
3,758 Posts
Happened to me and I had a faulty Fuel Pressure Sensor, easy fix and never happened again


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
206 Posts
But why would it happen everytime in a bit harder of a right turn, if its just a seensor?

How did yours happen? Right turns also?
 

·
Registered
Joined
·
3,157 Posts
But why would it happen everytime in a bit harder of a right turn, if its just a seensor?

How did yours happen? Right turns also?
Did you create a new account (medion_r) to ask for help with issues that you're having with the R that you're trying to sell?

I've had my R for a while (90k) miles 6 spd MT Not stock , yet not super modded.

some accumulative work done to the car: Snabb Intake , evolve Tune, Ipd Ignition Coils, Downpipe, Exhaust , FMIC, , CBV ,



Heres the deal: It has happened on and off - but with enough time in between each time it happens. Never freaked out about it since its probably an easy fix. But want to know what is going on?

It just happened again today (this is the 2nd or 3rd time here)
I was at the same intersection waiting to make a right, from a stop,
and when it was clear i took off in a bit of a hurry (but no spin or crazy launch or what not)
and right before it got straightened i went to put it in 2nd gear , then when i went to accelerate --there was NOTHING !
Car did not move (like it was off).. didnt revv up or anything?!? .
So i got it out of gear, revved it up a bit, and then clutch, and second gear again- and went normal from there.

It has also happened on other occasions, and i thought it was because it was lower on gas.. but this time it was 85% Full.. So, what gives?

Here is a pic of the exact intersection

[random funny thing. Somehow google maps street view took a pic of my caR when this happened Very strange coincedence ?!?!! ]





Can someone please give me any input/ ideas as to what is going on ?!

CEL came on for P0134 02 Sensor Circuit No Activity Detected (Bank I Sensor 1) - would this affect it ?

THANKS in advance
 

·
Registered
Joined
·
206 Posts
^^



Well its not a major priority that is a deal braker. Anyone buying one of these caR s knows they are very prone to doing stupid stuff like this.
I just didnt see ANYONE talk about this so i figured it wouldnt hurt to just ask as someone else lmao

w.e jig is up.

but yeah anyways.. Is there a recall on the pumps or what?
I plan on fixing it either way, and i was thnking today, and i think il keep it instead.
I kind of want a low mileage Clean E46.. but theyr NOT cheap lol, so i have some saving up to do haha.
 

·
Registered
Joined
·
3,788 Posts
Lol, this is going to be good....
 

·
Registered
Joined
·
3,758 Posts
But why would it happen everytime in a bit harder of a right turn, if its just a seensor?

How did yours happen? Right turns also?
mine was left turns lol

Also if you get an O2 sensor code how can it be your Fuel pump?

FPS is cheaper and an easier fix then a Fuel Pump but by all means do what you want.
 

·
Registered
Joined
·
1,028 Posts
If its the fuel pump, would it be affected by right turns only?
Fuel Pressure Sensor is on the left end of the fuel rail. So you can imagine if the sensor is faulty, that a hard turn could be read incorrectly by the FPS. It might then send out signals to choke off the gas. And depending on the fault, it might be a problem in the other turn direction as someone said theirs did.

Since mine is out, and I just put on a new sensor .. here ya go:

 

·
Registered
Joined
·
186 Posts
Fuel Pressure Sensor

My vote is for fuel pressure sensor. I had the same problem, it got progressively worse until I finally had it fixed. It is a simple repair, if I had the time I would have done it myself. I think the total cost of the repair was under $200. Since the repair, no problem.

Do a google search on "fuel pressure sensor", there are several threads on this. As I recall, one is a step by step repair using a Land Rover FPS.
 
1 - 14 of 14 Posts
Top