SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I have 2004 s60 2.4i. Firstly I started getting check engine code 0089 once a week or in two weeks, but car was running fine and I couldn't tell that something worked not like it should. But when I am in the traffic long enough (like 2 hours) car starts to stutter and it either goes away or I have to start engine again. It didn't occur to me when driving faster (40+) so far. Also if there is not much fuel in the tank 1/4 or 1/5 car can randomly stop and gas pedal will not respond (note that when this occurs, there is nothing in the dashboard) if I start engine again everything is fine and car runs smoothly.
I read the forums and found something similar, the solution was to clean mesh screen which is in fuel pump. I saw tutorials how to clean that in plastic fuel tanks, but my car has steel tank and fuel pump looks like this

I never did this and don't really know what to clean here so I am a bit afraid to damage fuel pump somehow. Maybe somebody can give me some advice or knows another possible solution to this problem? Maybe it's better just to change fuel pump if it doesn't work properly sometimes? Thanks
 

·
Registered
Joined
·
853 Posts
Not enough info here for your woe.
1.Amount of miles on the car
2.service history.How old is the filter.
3.I have never heard of anyone cleaning out the fuel pump screen.
4.Did ya check out the fuel pressure on the rail?
If I went that far as pulling the pump out of the tank,I would just get a new one and clean the tank before installing the new pump.It makes no sense to fiddle with a old pump.
 
1 - 2 of 2 Posts
Top