SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi.

The clutch pedal on my 2006 s40 t5 won't come back up after being pressed down. Also struggeling to select gears.

Probably a buggered master or slave cylinder or complete clutch.

The more worrying problem is that l'm getting "reduced engine performance" warnings.

Can this be as a result of the buggered clutch?

All this a weej before l'm going on a long trip.

Any advice is welcome.



Sent from my SM-J500F using Tapatalk
 

·
Registered
Joined
·
3,412 Posts
Definitely the clutch slave cyclinder, and I'm going to bet it's the crankshaft position sensor that causing the reduced engine performance code.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Thanks guys. I'm preparing myself for a whole clutch replacement but will be very happy if it is just the slave cylinder. Car is going in on monday. Will also get it scanned.

Will post the verdict.

Sent from my SM-J500F using Tapatalk
 

·
Registered
Joined
·
3,412 Posts
Brace yourself - from what I understand once the slave goes out it usually wipes out the clutch too (internal slave). When you install a new clutch you have to install a new dual mass flywheel (dual mass, you see, can't be resurfaced). If you can find a luk clutch kit, you may be able to get OTD with $1000 in parts.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
Turns out to be the master cylinder. Going to replace it and then wait for the slave to go. Then replace the clutch and everything needed inside

Sent from my SM-J500F using Tapatalk
 
1 - 7 of 7 Posts
Top