SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
501 Posts
Discussion Starter · #1 ·
Yes, I searched the thread. Possible issue could be plugs, coils, FPS, MAF, throttle body, TCV...

But wanted to explain if you experienced this unique situation. I have a 06 GT, tune, FMIC, stock TCV

When starting car (cold start), the RPM fires up to ~1800 then settles to ~750 which is normal. No RPM jump. But just when I hit "Drive" or "Reverse" on the GT, the RPM starts to float down then back up, then again a couple or few times, sometimes to where you think the car will stall.

Then after driving/warming up, it runs just fine between gears, Park, D and R. No RPM jumps. I suppose only cold start then runs fine when warmed.

Thoughts?
 

·
Registered
Joined
·
594 Posts
try cleaning the MAF first? it's the easiest and cheapest way to rule it out? nice to see another washington member!
 

·
Registered
Joined
·
501 Posts
Discussion Starter · #3 ·
Doesn't seem like the MAF...

I noticed it dips when I turn the steering wheel at idle speed. Is this normal?
 

·
Registered
Joined
·
3,313 Posts
Doesn't seem like the MAF...

I noticed it dips when I turn the steering wheel at idle speed. Is this normal?
I'd clean the MAF like hennessy mentioned; while the car is on, if the MAF is dirty the air and fuel is not right thus could making rough idle, RPM drops and dips but if you hit the gas pedal and it hesitates for a split second then revs up hard and fine but than rough idle, sounds like a MAF, or loose sensor or sometimes loose hose (usually around the MAF/intake area.

Turning the wheel while the car is on create more load, belts are turning and when going to lock right or left belts are actually moving faster needing a load, if the MAF is the culprit, you would see dips in RPM.

Now, there definitely could be other things, just don't want you to rule out the MAF right off the bat.
 
1 - 4 of 4 Posts
Top