SwedeSpeed - Volvo Performance Forum banner
1 - 13 of 13 Posts

·
Registered
2015 XC60 T6
Joined
·
26 Posts
Discussion Starter · #1 · (Edited)
I recently moved from Toronto, Ontario across the country to Victoria, British Columbia. My 2015 XC60 was moved by train. Before moving, the road sign information always worked perfectly in Ontario... the speed signs were always recognized, flawlessly. Upon arrival in BC, it stopped working. About 90% of the time, nothing is displayed. The other 10%, it is wrong (90 km/h displays as 30, or 110 km/h displays as 10, for example).

The formatting of the speed signs in BC is very slightly different than in Ontario. I think they may be using a different font. But they are still recognizably speed signs... not like the very different signs you see in Europe, for example. I thought this might be relevant because when I acquired the vehicle via Overseas Delivery in 2014, the speed signs in Sweden were not recognized and nothing was displayed. I was told that this was because the car had been programmed for it's final destination: Ontario, Canada.

My understanding is that the car uses the camera to detect speed signs, and it is programmed to recognize the signs for the region it is sold in. I don't know how granular the "region" setting is? A whole country, a province/state?

I took the car to Volvo of Victoria. The service manager said they have never encountered this problem before. They ruled out any physical issue with the camera and did a software update. The technician also stated that the SiriusXM traffic info was not working because there is no subscription. This was not a surprise to me - I only ever had the free six-month subscription when the car was new, and since I have never used the factory-installed navigation, I have never relied on the traffic info. Besides, as I said, speed signs in Ontario have been recognized flawlessly this whole time. I assume this is because the car uses only the camera to recognize signs, and the SiriusXM issue is irrelevant.

After the software update, they drove the car around the block and told me they weren't sure it was it was working yet. I assume that's because they are in the middle of the city and there are no speed signs on the city streets immediately around the dealership. I picked up the car and went directly to the highway. I passed several speed signs and nothing has changed. Mostly, nothing was displayed and occasionally the wrong speed limit was shown, just like before I took it in.

This may seem like a small issue, but I really want it resolved. Now that I live in a new area and I'm not familiar with the roads and speed limits, I find the speed limit display useful. Also, if I sell the car in the future, it has one less feature.

I will take the car back to the dealership for more investigation. Meanwhile, does anyone here have ideas?
 

·
Registered
Joined
·
516 Posts
I'm from the Island too and the 2015 T6 Platinum works perfectly for speed information. The DIM always displays the correct speed in the CRD and on all highways (e.g. the Pat Bay). Interesting that yours does not work correctly.


When was the last time you updated the Sensus software and maps via the USB download method? Do you know exactly what they updated / the firmware part numbers?

When I last updated the 2015's maps, I had to use this downloader vs the one intended for 2014 and newer models: Download maps | Volvo Support
Out of curiosity, does your 2015 have the globe icon or is it blank:

130202
vs
130203
 

·
Registered
Joined
·
516 Posts
What part of the Victoria/CRD are you located? The next time I'm driving the 2015 through that area I'll pay extra attention if it's working correctly.
 

·
Premium Member
Joined
·
2,346 Posts
I would guess it's two things. First is as you thought if the sign format is different then there is probably a software pack to update the region. If it can not recognize the signs it can't relay the information. And second is the mpas. Normally it defaults to the mapping data for the information and then if it sees a sign with different info, it assumes the sign is correct and overrides the map data. Map updates are regional at least here in the US. I would try to make sure the maps are up to date, simply to give a better navigational experience for starters, but then to help resolve this problem. But then ask the service department to look into if there is a regional update that would include signs. NOt sure either of these will resolve anything, but it makes sense in my head to start there anyhow.
 

·
Registered
2015 XC60 T6
Joined
·
26 Posts
Discussion Starter · #5 ·
I'm from the Island too and the 2015 T6 Platinum works perfectly for speed information. The DIM always displays the correct speed in the CRD and on all highways (e.g. the Pat Bay). Interesting that yours does not work correctly.


When was the last time you updated the Sensus software and maps via the USB download method? Do you know exactly what they updated / the firmware part numbers?

When I last updated the 2015's maps, I had to use this downloader vs the one intended for 2014 and newer models: Download maps | Volvo Support
Out of curiosity, does your 2015 have the globe icon or is it blank:

View attachment 130202 vs View attachment 130203
Volvo of Victoria did the following software updates:

31667211 RTTI Application
31268488 ICM/IHU Upgrade

I do not have the globe icon on the button panel.

I have never updated the maps, because I have never used the navigation system (I use my phone - Waze and Google Maps are easier to use). Looking at the link you provided, though, the map update covers all of North America, so I assume that Vancouver Island maps are already in the car. But I'll turn on the maps to see what happens, and try the update. Thanks!
 

·
Registered
2015 XC60 T6
Joined
·
26 Posts
Discussion Starter · #7 ·
I would guess it's two things. First is as you thought if the sign format is different then there is probably a software pack to update the region. If it can not recognize the signs it can't relay the information. And second is the mpas. Normally it defaults to the mapping data for the information and then if it sees a sign with different info, it assumes the sign is correct and overrides the map data. Map updates are regional at least here in the US. I would try to make sure the maps are up to date, simply to give a better navigational experience for starters, but then to help resolve this problem. But then ask the service department to look into if there is a regional update that would include signs. NOt sure either of these will resolve anything, but it makes sense in my head to start there anyhow.
Thanks, I will update the maps and ask the dealership about a regional update.
 

·
Registered
2015 XC60 T6
Joined
·
26 Posts
Discussion Starter · #8 ·
Thanks, I will update the maps and ask the dealership about a regional update.
Update: I downloaded the 18GB map update and attempted to load it via USB. No luck. The only way to update, apparently, is using DVDs. I remember getting an update package of DVDs when the car was about a year old. I did the update at the time, and it took forever.

However, I used the navigation today for the first time in about six years and it worked just fine. It had all the local maps and could find Home Depot 15km away. So I can't imagine how an update to the maps at this point would help the road sign information situation.

I'll be going back to the dealership tomorrow. If I have an update, I'll post here.
 

·
Registered
Joined
·
516 Posts
Update: I downloaded the 18GB map update and attempted to load it via USB. No luck. The only way to update, apparently, is using DVDs. I remember getting an update package of DVDs when the car was about a year old. I did the update at the time, and it took forever.

However, I used the navigation today for the first time in about six years and it worked just fine. It had all the local maps and could find Home Depot 15km away. So I can't imagine how an update to the maps at this point would help the road sign information situation.

I'll be going back to the dealership tomorrow. If I have an update, I'll post here.
There's a firmware update for the Sensus Navigation that allows you to update it using a USB stick. The 2012 has that update now can be updated over USB (when it originally started with the mail-out free DVD updates). I also update the 2015 via USB.

There also is this maps downloader which you'd think would work for our Canadian 2015 vehicles, but it doesn't: Download maps | Volvo Support

I'll read in VIDA if there's more information how the camera sign system works (in case there's another subsystem that needs a firmware update).
 

·
Registered
Joined
·
516 Posts
I'm in Gordon Head.
I drive through Gordon Head all the time (probably will next weekend). I'll see if it works or doesn't. the 2015 works perfect through Mt. Doug for example.
 

·
Registered
Joined
·
516 Posts
I'd also ask if they could do a "Total Upgrade" of all the vehicle's modules.
 

·
Registered
Joined
·
164 Posts
Cant see it mentioned, but I assume you haven't accidentally deselected the option in the MYCAR settings?
 

·
Registered
2015 XC60 T6
Joined
·
26 Posts
Discussion Starter · #13 ·
Cant see it mentioned, but I assume you haven't accidentally deselected the option in the MYCAR settings?
Yeah, I've checked that several times :) I've also toggled it off and on to see if that helps. It is currently ON.
 
1 - 13 of 13 Posts
Top