SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
171 Posts
Discussion Starter · #1 ·
For those of you that have the RICA tune in their cars, what coils are you currently running? Mine are still stock but at 115k miles, I am starting to see slight stumbles at high RPMs. Plugs are OEM and almost new. Just wondering if I should stay stock or go with IPD coils. I have had the tune for about 25k miles and it has performed great.
Thanks,
Neil
 

·
Registered
Joined
·
2,586 Posts
you could be having problems because they are 115k miles old lol. get new ones along with new plugs and i think youll be fine


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,621 Posts
Coils are either good or bad. They are not wearable items. OE coils are all you could ever need to jump the correct spark gap.
 

·
Registered
Joined
·
1,695 Posts
Why no go in and tune it all up? Gap the plugs, clean off electric connections with e-cleaner (while looking for any signs of oxidization), reapply dielectric grease to the CP's, and clean up/replace any of the shielding tubes that cover the wires? I am a few weeks away from grabbing a daily driver and once that is done my R is getting pulled apart ;-)

I had 2 tunes from RICA for my S40 T5, did a stage 1 then the debated Stage 2+/3 and I did have the same thing happen to me, turned out to be a CP which was on it's way out, I got misfires shortly after the stumbling and the CEL would blink a couple times. I bought new CP's from FCP and the problem went away. I checked the model numbers recently because they are still in my garage but it turns out that they fit my R so I have extras. 2 boxes of plugs too.
 

·
Registered
Joined
·
2,586 Posts
Why no go in and tune it all up? Gap the plugs, clean off electric connections with e-cleaner (while looking for any signs of oxidization), reapply dielectric grease to the CP's, and clean up/replace any of the shielding tubes that cover the wires? I am a few weeks away from grabbing a daily driver and once that is done my R is getting pulled apart ;-)

I had 2 tunes from RICA for my S40 T5, did a stage 1 then the debated Stage 2+/3 and I did have the same thing happen to me, turned out to be a CP which was on it's way out, I got misfires shortly after the stumbling and the CEL would blink a couple times. I bought new CP's from FCP and the problem went away. I checked the model numbers recently because they are still in my garage but it turns out that they fit my R so I have extras. 2 boxes of plugs too.
At 115k i would recommend new plugs not re gap them but thats just my .02
 
1 - 6 of 6 Posts
Top