SwedeSpeed - Volvo Performance Forum banner

1 - 19 of 19 Posts

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #1 ·
A few weeks ago I took out the instrument cluster in a '92 244, and when I put it back in the trip odometer and odometer ceased to function. I pulled it out again, took it apart, and true to form all the gears were in perfect condition-teeth and all. It took about 60 miles of driving for the odometer/trip odometer to begin working, and they continued to work even after I reset the trip odometer some three times after going some 200 plus miles.<p>Last Saturday I took out the cluster(without disconnecting any wires) to take a picture of the back, and when I had put it back in, the odometer and trip odometer had once again decided not to work. How I should tackle this I do not know. Any help would be greatly appreciated....Thanks <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"><p>p.s. Sorry for the same topic being contionously rehashed <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Premium Member
Joined
·
19,953 Posts
Re: Reoccuring issue with the odometer and trip odometer...... (1sciroccofahrer)

Drive around for a while and all may begin working fine again.<br>George Dill<p>
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #3 ·
Re: Reoccuring issue with the odometer and trip odometer...... (gdill2)

Will do George! Have a good one <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #4 ·
Re: Reoccuring issue with the odometer and trip odometer...... (1sciroccofahrer)

The odometer and trip odometer still haven't begun working again <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> I can still move the numbers manually, but after having replaced the antenna mast yesterday evening, this is one of the last issues troubling the '92 240. Thanks in advance <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0">
 

·
Premium Member
Joined
·
19,953 Posts
Re: Reoccuring issue with the odometer and trip odometer...... (1sciroccofahrer)

Time to pull the panel again?<p>George Dill<p>
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #6 ·
Re: Reoccuring issue with the odometer and trip odometer...... (gdill2)

I am afraid so <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> Once I get the odometer and trip odometer working again, I am never going to pull the cluster-even though, after all this time, I am quite proficient at it <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0"> <BR><BR>
<i>Modified by 1sciroccofahrer at 1:15 PM 4-27-2006</i>
 

·
Registered
Joined
·
636 Posts
Scirocco, <p>Check these pix out on this link....<p><A HREF="http://www.homestead.com/volvo2/88speedo.html" TARGET="_blank">http://www.homestead.com/volvo2/88speedo.html</A>
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #8 ·
Re: (DVolvoguy777)

Thanks VolvoGuy...Those photos will be quite helpful indeed! When I return home this afternoon, I am going to take the cluster out, bring it into my computer room, and have another look at it. Have a splendid afternoon one and all <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/embeer.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #9 ·
Re: (1sciroccofahrer)

I just pulled the cluster, and took a look at all the gears, and they are in great shape with all of their teeth intact. I am going to take the car out later to go to the grocery, and I can only hope that the odometer/trip odometer begin to work once again. Have a most wonderful evening <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Registered
Joined
·
412 Posts
Re: (1sciroccofahrer)

you may have to take it into a speedometer shop to get it diagnosed. im sure theres one in your area. i know this probably isnt the answer you were looking for but it seems to be out of the reach of anyone but a specialist.<p><br>this is a bit off topic but Sprechen sie Deutsch? <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #11 ·
Re: (Camyman)

There is indeed a Speedometer repair facility a little less than eight miles from where I am, but I am not yet at the point where I am going to admit defeat. A week from now I might just be singing another tune <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> <p>Eigentlich kann ich leider kein Deutsch sprechen, aber Bayerisch(Frankisch) kann ich <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0">
 

·
Premium Member
Joined
·
19,953 Posts
Re: (1sciroccofahrer)

<A HREF="http://www.hyperocity.com/volvo240/volvoodometer.htm" TARGET="_blank">http://www.hyperocity.com/volv...r.htm</A><p><A HREF="http://www.odometergears.com" TARGET="_blank">http://www.odometergears.com</A>/<p>
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #15 ·
Re: (gdill2)

Thanks George! I will give them a ring on Monday <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #16 ·
Re: (1sciroccofahrer)

Because I was done with all my chores for the day, I pulled the instrument cluster and took another look at all the gears. Both the small white gear, and the larger black gear were in perfect condition, so I put the cluster back together and took the car for a spin. True to form, it would not work. I am going to pull the cluster again, and see if I can't try out a few variables, and who knows, I might just get lucky <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0"> Hope everyone here is enjoying their Saturday <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/embeer.gif" BORDER="0">
 

·
Registered
Joined
·
412 Posts
Re: (1sciroccofahrer)

when you have it out see if the gears turn the numbers. if not then id run outside as soon as possible in a bathrobe with a bedpan and a wooden spoon and walk down the middle of the street banging on the bedpan with the wooden spoon screaming "the swedish are coming, the swedish are coming!" then try a dabble of white lithium grease on the gears and try again.
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #18 ·
Re: (Camyman)

I am able to manually move the odometer/trip odometer when I have taken the side out of the speedometer cluster and the little(and big) gear are out. I will try the white lithium grease trick tomorrow and see how it works out <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"> Have a great Saturday evening Camyman <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/embeer.gif" BORDER="0">
 

·
Banned
Joined
·
1,241 Posts
Discussion Starter · #19 ·
Re: (1sciroccofahrer)

I took the speedo cluster out, with the little and big gears still in, and was able to manually move the numbers. I applied a little lithium grease (with a q-tip) to both the small and big gear(s), and after I reassembled everything the odometer/trip odometer still wouldn't work. I have a theory that perhaps when I take out the small and big gear(s) that perhaps when I put them back the small gear isn't making contact to the to clear plastic piece. Now that I have mowed the lawns and cleaned the bathrooms, I can devote the afternoon to this ongoing conundrum <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/embeer.gif" BORDER="0">
 
1 - 19 of 19 Posts
Top