SwedeSpeed - Volvo Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
i all,

my girlfriend drives a 2006 XC90 V8 and had the rear passenger hub go. When I removed the 4 hub bolts and the axle bolt I noticed that the end of the CV axle had already started to mushroom. After two days of PB blaster, a torch, three prong puller and a BFH, the hub has officially won. I found an axle for $100 and I’m just going to replace the whole thing.

My new problem: Although I have the axle sliding out of the differential, I can’t fit the hub and axle through the opening on the hubs housing. It seems like there is a small tab that is blocking the axle from sliding through. Does anyone have any experience with this?

https://ibb.co/7NhPNVK
 

·
Registered
Joined
·
1,279 Posts
I think “normally” you would take the two parts apart which would avoid having to push the axle through the spindle. Could you get in there with an angle grinder and take the tab off? Otherwise do you have enough space to take the axle apart?


2002 V70XC, 2003 V40, 2004 S60, 2010 V70
 

·
Registered
2008 XC90 3.2
Joined
·
1,365 Posts

·
Registered
Joined
·
3,267 Posts
https://forums.swedespeed.com/showt...g-(hub)-amp-wheel-speed-sensor-tons-of-photos for reference

I suspect that tab is your wheel sensor as well, there's a 10mm bolt right over the top of the back of the hub knuckle (bearing housing).

Axle stub should have had a SEMS screw on with a big washer on it (inside hub center). If the axle stub end is mushroomed, my guess is someone has been pounding on it.

Rear wheel bearings are a PITA to get off, I have near zero corrosion under my vehicle and I've still had to pound on the hubs to get them free from the housing. I've used the wheel bolts on a closed wrench to lever while I pound on the hub from the sides, even then it's been tough.

Consider installing the mudflap when you replace the bearing- https://forums.swedespeed.com/showthread.php?577363-Wheel-Bearing-Mudflaps
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #5 ·
Good call guys thank you. Took off the bolt off and sensor came with it.

Now of course the boot doesn’t fit through the opening... barely. I’m going to try to clean up the opening tomorrow when there’s more light. Hopefully I don’t have to cut it off.

https://ibb.co/rmFQxdQ
 
1 - 5 of 5 Posts
Top