SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
186 Posts
Discussion Starter · #1 ·
So I had to rescue the wife today, the remote would not come out of the dash after shut down. The mechanism has been a bit noisy etc recently, we were not able to restart the car, nor lock all the doors by the key. Disconnecting the battery and reconnecting it, allowed the car to start, so she could at least get home. It's at home with the remote still in the dash. Any ideas? Can I squirt contact cleaner in there? Or a penetrant spray? Something else maybe?
 

·
Registered
Joined
·
1,994 Posts
So I had to rescue the wife today, the remote would not come out of the dash after shut down. The mechanism has been a bit noisy etc recently, we were not able to restart the car, nor lock all the doors by the key. Disconnecting the battery and reconnecting it, allowed the car to start, so she could at least get home. It's at home with the remote still in the dash. Any ideas? Can I squirt contact cleaner in there? Or a penetrant spray? Something else maybe?
Try putting your foot on the brake and running the shifter though the gears and back to park. Then check to make sure the shift lock isn’t stuck in. If it is you may have to wiggle/work the button a bit to free it up us a small touch of lubricant on that area and let it sit for a few minutes and then try to free it up again. Make sure all of the buttons on the shifter also return to their neutral position. The car thinks its still in gear.
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #3 ·
So I've had another look, if I disconnect the battery and reconnect, the car will start and the dash shows that the vehicle is in park, moving the selector to drive, the dash reports reverse, neutral and drive. I've put some lubricant in the fob hole, and into the gear selector with no change. The selector locks into park and I can turn off the engine, normally I can restart the engine without pulling the fob out, but as it is now once it's turned off the ignition cannot be turned on again unless I disconnect the battery.
 

·
Registered
Joined
·
1,994 Posts
So I've had another look, if I disconnect the battery and reconnect, the car will start and the dash shows that the vehicle is in park, moving the selector to drive, the dash reports reverse, neutral and drive. I've put some lubricant in the fob hole, and into the gear selector with no change. The selector locks into park and I can turn off the engine, normally I can restart the engine without pulling the fob out, but as it is now once it's turned off the ignition cannot be turned on again unless I disconnect the battery.
Not sure but maybe worth a try.....
The button on the shifter is all the way out When back in park?
 

·
Registered
Joined
·
883 Posts
Mine was acting up and had the replace the "switch" or ignition housing that key fits into
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #6 ·

·
Registered
Joined
·
883 Posts
How is that mechanism removed from the dash?
Pull cluster and it bolts in from back. Easy to do, but DOES have to be programmed/coded at dealer, so wont run with new one
 

·
Registered
Joined
·
186 Posts
Discussion Starter · #8 ·
Pull cluster and it bolts in from back. Easy to do, but DOES have to be programmed/coded at dealer, so wont run with new one
Can it be coded by VIDA? I have working VIDA here?
 
1 - 9 of 9 Posts
Top