SwedeSpeed - Volvo Performance Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Mike:<p>I have a very weak rear window defogger. I have sanded the electrical connectiions around the rear window. I have made sure the defogger lines are painted on without breaks. I have replaced the switch. It only lights up for the high mode, not the low mode. The only thing I have not done is replace the defogger relay, under the hood. Where do I get one of these? Is it a 12 volt - 30 amp? Is there still an in stock part number?
 

·
Registered
Joined
·
1,016 Posts
Re: Rear Window Defogger (Ted)

Ted:<p>I thought I responded to this earlier but it's not here <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/confused.gif" BORDER="0"> so ...<p>If the relay was bad you wouldn't even get what you have.<p>Since the lamp doesn't work in the low mode you have an some open grids (they may look good but they oxidize).<br>Get a voltmeter and put the switch in low. You should measure around 6 volts on the right window terminal and 12 volts on the non ground terminal on the left top. This will confirm that one half the grid lines are open.<br>Now with the switch in the high position. Measure the voltage on the middle of the grid lines. You should get 6 volts. you can find the open by moving the voltmeter lead towards the right side, which will have 12 volts on the terminal, so the voltmeter will indicate 12 volts when the voltmeter lead gets to the working end of the open.<p>Hope this helps.
 
1 - 2 of 2 Posts
Top