SwedeSpeed - Volvo Performance Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
592 Posts
Discussion Starter · #1 ·
I need a new one. Does the base s60 use the same fan? That way I can check out the jy today.. Thanks all

Sent from my ZTE A2017U using Tapatalk
 

·
Registered
Joined
·
144 Posts
It depends on the year? But the same fans are used in all p2 variants.

Sent from my SM-G955U1 using Tapatalk
 

·
Registered
Joined
·
144 Posts
I dont remember the year change. But 05 and up. Should be fine. Check an 04 and see.

Sent from my SM-G955U1 using Tapatalk
 

·
Registered
Joined
·
144 Posts
Also check the 60 amp fuse. Its buried under main fuses in the engine compartment. You have to dissect the fuse box. And it not available at parts stores. So rob a few at the jy

Sent from my SM-G955U1 using Tapatalk
 

·
Registered
Joined
·
592 Posts
Discussion Starter · #7 ·
Also check the 60 amp fuse. Its buried under main fuses in the engine compartment. You have to dissect the fuse box. And it not available at parts stores. So rob a few at the jy

Sent from my SM-G955U1 using Tapatalk
Got it thanks! My code is "6200 "engine cooling fan control module" "not the same code you got but Ill check the fuse too. Oddly enough Alldata and Mitchell have zero info on this code. Anyone happen to know? I'm just assuming the fan is out, I will say that my alternator is failing and waiting for a new one, not sure if it's related because it's not like the battery is dead yet, still had great voltage and cca

Sent from my ZTE A2017U using Tapatalk
 
1 - 10 of 10 Posts
Top