SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 22 Posts

·
Registered
Joined
·
495 Posts
Discussion Starter · #1 ·
So I was on the way into work this morning and turning on to HWY 37 from a stop light pulling some revs (around 5800) going to grab 4th when she started bucking and the throttle went dead. The message center said “Engine Performance Reduced” so I pulled over and she was idling but the throttle was still dead, I turned her off and restarted the car she was running rough, the check engine light was on and the message center said something like “Engine system service required” I limped to the next exit when she lost power again and this time the message center said “Engine System Service Urgent”. I called my neighbor with a trailer and took her to the dealer and have not heard back yet any ideas? Picture of car on trailer to follow later.<br>
<A HREF="http://s341.photobucket.com/albums/o371/CM2RAS/?action=view&current=DSC01774.jpg" TARGET="_blank"><IMG SRC="http://i341.photobucket.com/albums/o371/CM2RAS/DSC01774.jpg" BORDER="0"></A><BR><BR>
<i>Modified by CM2RAS at 7:30 PM 6-4-2009</i>
 

·
Registered
Joined
·
1,185 Posts
Re: Rachel left me stranded has anyone ever had this happen? (CM2RAS)

Could be lots of things, but sounds similar to when my fuel pressure sensor failed.<p>I took a right turn at a light, pressed the throttle and it started bucking and coughing and I slowly coasted to the shoulder. It would idle but not take any throttle. Flat-bedded it to the dealer. This was before the recall on the sensor.
 

·
Registered
Joined
·
926 Posts
Re: Rachel left me stranded has anyone ever had this happen? (CM2RAS)

Throttle completely dead, or just no boost? If the latter, given the high RPMs, have an air line burst or one of the connections pop off?
 

·
Registered
Joined
·
63,543 Posts
Re: Rachel left me stranded has anyone ever had this happen? (CM2RAS)

Perhaps if you didn't call the car<B> Rachel,</B> this probably would not have happened.<br>SHE <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/rolleyes.gif" BORDER="0"> was pissed off for giving here that bloody awful name! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/sly.gif" BORDER="0">
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #5 ·
Re: Rachel left me stranded has anyone ever had this happen? (michaelc)

Completely dead but would still idle I am thinking MAF sensor?
 

·
Registered
Joined
·
7,954 Posts
" wastegate tweak "<p>Overboost? Into Limp mode?<p>Any other mods?
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #7 ·
Re: (chinaonnitrous1)

JRL: sorry your not fond of the name Rachel. Some of the most gorgeous and wonderful women I have ever known have been named Rachel.<p>China: I never got around to doing the wastegate mod, it is funny because I was going to do it last night.
 

·
Registered
Joined
·
7,954 Posts
Probably the Fuel sensor thingy. There was a recall/bulletin on it.<p>Is your VIN affected? you might want to check/suggest.
 

·
Registered
Joined
·
905 Posts
Re: (chinaonnitrous1)

sounds like MAF<p>PS: wasnt rachel the name of the car in that old car movie where is was possessed or something?
 

·
Registered
Joined
·
747 Posts
Re: (lan)

That was Christine...... <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0">
 

·
Registered
Joined
·
2,969 Posts
Re: (lan)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>lan</b> »</i></TD></TR><TR><TD CLASS="quote">sounds like MAF<p>PS: wasnt rachel the name of the car in that old car movie where is was possessed or something?</TD></TR></TABLE><p>That would have been Christine <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/wink.gif" BORDER="0">
 

·
Registered
Joined
·
7,954 Posts
Re: (lan)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>lan</b> »</i></TD></TR><TR><TD CLASS="quote">sounds like MAF<p>PS: wasnt rachel the name of the car in that old car movie where is was possessed or something?</TD></TR></TABLE><p>IF its the MAF, unplug it.<p>If it idles fine then so be it.<p>Otherwise its something else.
 

·
Registered
Joined
·
1,844 Posts
When my fuel rail pressure sensor went I just got a CEL no engine system message so I am not sure if it's that. Hopefully it is something that simple though! Good luck.
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #14 ·
Re: (crimnlmnded)

Thanks for all the help guys the dealer called and it is the MAS. but it is due for a timing belt.
 

·
Registered
Joined
·
658 Posts
Wow, suprised a MAF would leave you stranded...well guess i'm not too suprised.<p>Unplugging it in most cars will put the ecu in limp mode, car will run / drive.<p>
 

·
Registered
Joined
·
7,954 Posts
Can you have them save the MAF, I'd like to take a look/salvage it if its okay...
 

·
Registered
Joined
·
11,628 Posts
Re: (CM2RAS)

When doing your T-Belt you should also do your water pump since everything is opened up down there.
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #18 ·
Re: (850arrrsaylikepirate)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>850arrrsaylikepirate</b> »</i></TD></TR><TR><TD CLASS="quote">When doing your T-Belt you should also do your water pump since everything is opened up down there.</TD></TR></TABLE><p>Pirate: Great idea <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> anything else I should be considering while she is opened up? (Lets not get to crazy)
 

·
Registered
Joined
·
495 Posts
Discussion Starter · #20 ·
Re: (Johnr352)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Johnr352</b> »</i></TD></TR><TR><TD CLASS="quote">Sleeve your cylinders?</TD></TR></TABLE><p>I was thinking of have 4340 H beam rods and crankshaft installed.
 
1 - 20 of 22 Posts
Top