SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 38 Posts

·
Registered
Joined
·
295 Posts
Discussion Starter · #1 ·
Hi all, I recently moved to Woonsocket RI from Minnesota. Today Driving on 495 I hit a large pothole that I couldn't possibly dodge. I now have an anti skid service required message, the hit also exacerbated a power steering leak that I have been putting off repair of. The question is, since I am new to the area I have not found someone knowledgeable about the R's yet to work on it. Tasca seems good but I don't want to foot the bill for a dealer to look at it. Can anyone recommend a shop in RI? I am willing to drive a little way for someone trustworthy.

Also posted this in the NE regional thread.

I know the accelerometers can get knocked loose from the strut, where are these located? How do I check them? Could it have just destroyed the strut? These were due to be replaced soon anyway but I really don't have the cash to spend on it at the moment. Crazyace and I are going to hook it up to his VIDA/DICE next week, will that be able to tell us what the issue is?
 

·
Registered
Joined
·
3,758 Posts
VIDA should be able to let you know what is wrong when it scans the car for errors.

Good luck. I'm amazed your wheel isn't toast.
 

·
Premium Member
Joined
·
10,797 Posts
Hi all, I recently moved to Woonsocket RI from Minnesota. Today Driving on 495 I hit a large pothole that I couldn't possibly dodge. I now have an anti skid service required message, the hit also exacerbated a power steering leak that I have been putting off repair of. The question is, since I am new to the area I have not found someone knowledgeable about the R's yet to work on it. Tasca seems good but I don't want to foot the bill for a dealer to look at it. Can anyone recommend a shop in RI? I am willing to drive a little way for someone trustworthy.

Also posted this in the NE regional thread.

I know the accelerometers can get knocked loose from the strut, where are these located? How do I check them? Could it have just destroyed the strut? These were due to be replaced soon anyway but I really don't have the cash to spend on it at the moment. Crazyace and I are going to hook it up to his VIDA/DICE next week, will that be able to tell us what the issue is?
I gotcha ;)
 

·
Registered
Joined
·
2,137 Posts
It could be the sensor that got knocked out of wack when you hit the pothole. Since the anti skid light came on only after you hit it. Vida will tell you what the problem is when you hook it up.
 

·
Registered
Joined
·
2,418 Posts
Get an alignment?
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #7 ·
VIDA should be able to let you know what is wrong when it scans the car for errors.

Good luck. I'm amazed your wheel isn't toast.
That was my first thought too! Fingers crossed that the wheel is still holding air when I look at it in the morning.
 

·
Premium Member
Joined
·
8,700 Posts
^ No, that's the ABS sensor. The accelerometer is higher up on the strut, it's mounted on the opposite side of where the top of the endlink balljoint fastened.

If it's an accelerometer, the message you should be seeing is "Chassis Service Required" which is directly related to the suspension 4C.

"Anti-Skid Service Required" is something entirely different and related to the DTSC system(traction). And depending on the series and sequence of error messages that appears, it could range between a wheel bearing, ABS sensor, speed sensor, steering sensor, yaw sensor or the DEM.
 

·
Registered
Joined
·
2,137 Posts
^I should of read a little bit more. Here is a pic of the accelerometer. (#4)
Left- 30782311
Right- 30782312



Hope this helps.
 

·
Registered
Joined
·
228 Posts
A pot hole wouldn't cause a dem failure trust me I would know haha
 

·
Premium Member
Joined
·
10,797 Posts
Well let's put it this way all knowing Gabe young.

I read his codes yesterday and the dem is what popped up. So HA
 

·
Registered
Joined
·
228 Posts
I'm saying a short somewhere still you asshat
 

·
Registered
Joined
·
295 Posts
Discussion Starter · #20 ·
Bingo! Bad connection and a software update and we are good to go. Replaced a ps line and that works too. $200 not too bad. The $600 on tires hurt a little more.
 
1 - 20 of 38 Posts
Top