SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7,476 Posts
Discussion Starter · #1 ·
I got two problems with my trunk:
1. It is reported as opened to the on-board computer - the tail lights are on, the internal lights are on, the instrument cluster displays the Trunk opened warning, and the car does not close, since it considers that the trunk is opened, even if it is tightly shut.
2. The fuse that protects the trunk circuits goes off every couple of hours if i keep replacing it. And even without the fuse, the tail lights are on while the lid is shut, draining the battery.

Does someone can see the common cause?
Bad lock actuator? Bad proximity/lumit switches that turn the tail and internal lights on and off?
Anything else?

Sent from my SM-N910P using Tapatalk
 

·
Moderator
Joined
·
3,391 Posts
To me it sounds like a short in the wiring to, or within the switch which senses when the trunk is closed or open. That would cause all of the symptoms. Using a multimeter, check the continuity of positive wire going from the fuse box (REM) to the switch. If that checks out, it's the switch itself. If it doesn't check out, trace the wire to find the short, or run a replacement wire. If there is a short within the wire, and the switch is in the trunk lid latch (I think it is), i would bet the short is in the grouping of wires which runs from the trunk lid to the interior of the trunk since those wires flex when the trunk is opened and closed.
 

·
Registered
Joined
·
7,476 Posts
Discussion Starter · #3 · (Edited)
Thank you, I suspect the short and do not know where that switch is. It is hidden somewhere under the covers. Does anyone have a wiring diagram?

Sent from my SM-N910P using Tapatalk
 

·
Registered
Joined
·
174 Posts
Hello!I have this problem on my s80 also.Got the lining off,opened up the latch,but nothing seems to be wrong with it.I have positive power in the switch cable also.The strange thomg is that it engages by itself(latch closes/engages and tail lights go on),only when it is quarter way down from closing the lid.At a very small dostance from closing it comes alive,but fully opened it is dead.Have you figured it out since then.I suspect a shortcircuit from one of the wires in the loop.Thanks!
 

·
Registered
Joined
·
204 Posts
BMWs are famous for damaging the wires in the hinge area... The volvo design is prtty similar, so I would look there first..
 

·
Registered
Joined
·
1,692 Posts
If there'a a short circuit I think there should be an error code. I installed the handle lightings in my car and my shoddy electrical work seems to trigger error codes if I use the dimmer for the interior lighting, saying there's a short to ground. If there's such a DTC for the boot lid handle it might narrow down which wires to look at, if you have a wiring diagram at hand at least.

I don't exactly know what you mean though by it being dead when it's open and something coming alive when you're near to closing the lid?
 
1 - 6 of 6 Posts
Top