SwedeSpeed - Volvo Performance Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
I am not sure what's going on with my volvo.. I turn the key and sometimes the car doesnt wanna start, i take the key out, try again, and it starts. My signals are occasionally not working and same with my gas pedal. I was thinking the key might be sending bad signals to the computer since it's programmed to the car.. because my brother decided to superglue it together when he broke it. He said he saw an immobilizer message but I still haven't seen one. What do you guys think it could be? Battery?! Help please !
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #3 ·
Okay I checked out my battery and the positive (I think) isnt secured tightly. It stays in place but i can pull it out without unscrewing anything. Could that be the problem? Also there wasnt any screw to tighten it ...
 

·
Registered
Joined
·
9,114 Posts
Definitely a possibility. Would correct the power issue and then monitor for future issues. The start control modules are also problematic as well.
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #6 ·
I was thinking it's the key fob too, Volvo wanted 250 for a new key to be programmed so I decided to see if it was something else.. I don't know how to tighten the battery since there isn't any screws though. I am most likely going to try a new key Tuesday if I dont get it solved by then!
 

·
Registered
Joined
·
326 Posts
my father had a problem where he would try to start his car, and when he turned the key over, it was like there wasnt even a battery hooked up. It wouldnt turn over.. wouldnt do anything.. After he replaced the key fob, everything was back to normal.

As for the turn signal, and the gas pedal issue, I have no idea... it could have something to do with the fact that your car could be thinking is being stolen?

Do you have a spare key that you could troubleshoot with?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
No I do not have a spare key.. Tomorrow I will try to somehow tighten the battery or maybe even try putting a new one on and Ill see if anything fixes from that. Since Volvo isn't open tomorrow (today technically) I will get my new key fob Tuesday and hopefully solve the problem.
my father had a problem where he would try to start his car, and when he turned the key over, it was like there wasnt even a battery hooked up. It wouldnt turn over.. wouldnt do anything.. After he replaced the key fob, everything was back to normal.

As for the turn signal, and the gas pedal issue, I have no idea... it could have something to do with the fact that your car could be thinking is being stolen?

Do you have a spare key that you could troubleshoot with?
 

·
Registered
Joined
·
1,330 Posts
Okay I checked out my battery and the positive (I think) isnt secured tightly. It stays in place but i can pull it out without unscrewing anything. Could that be the problem? Also there wasnt any screw to tighten it ...
THAT!!!

From my time at a car parts retailer (where most sales are bulbs, oil, and batteries): if you can spin or remove the terminal from the battery, it is not tight enough. It will make it look like the battery is going bad. I can bet that if you take a voltometer to it, it will still show ~12 volts, but its the amps that need that super solid connection.

Couple ways to fix it in order from the least ghetto, to "oh my goodness, this is a volvo, not a pinto."
1) Get a completely new cable (which will have the new terminal attached all pretty-like from the factory).
2) Go to your local parts house and get a new terminal, hack the old one off of and attach it to the cable you currently have.
3) Get some aluminum foil and wrap it around the terminal to make the terminal larger and therefore easier to clamp to.

Wait, wait, where the hell is your bolt/nut/screw for tightening?!

Let me get a pic of mine.
 

·
Registered
Joined
·
1,330 Posts
HA HA! Found it...

You tighten that nut with the red wire attached (the red wire is aftermarket) and it pulls a v shaped block upwards, pushing the prongs that go around the battery terminal together.



Does yours look like this?
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #11 ·
Yes, i found the screw right next to my wipers, the mechanic probably forgot to put it back on after messing with the battery. But my friend has the volvo software and he did a software restart and now my signals and gas pedal work all the time.. my speedometer is still not working.
HA HA! Found it...

You tighten that nut with the red wire attached (the red wire is aftermarket) and it pulls a v shaped block upwards, pushing the prongs that go around the battery terminal together.



Does yours look like this?
 

·
Registered
Joined
·
64 Posts
@Adrenaline406: That's a teeny power lead if it is going to an amplifier. Is it 10 gauge? Post your set up!

(I'll post mine as soon as my ****ing V50 is out of the repair shop.)
 
1 - 12 of 12 Posts
Top