SwedeSpeed - Volvo Performance Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter · #1 ·
Paid Evolve to upgrade ECU (actually done by Powerchip) and have had problems from start. After initial issue involving idle (which required me to send ECU to Powerchip second time so they could exclude everything below 1000 rpms from re-mapping), ran fine for a couple of days and then started experiencing loss of throttle response, especially on hard acceleration. Exchanged many emails with Powerchip as problem progressively got worse. They are convinced it is air flow sensor problem, not ECU. (Apparently it's not all that uncommon for sensors to fail after ECU upgrade, which I didn't know.) So paid $244 + shipping for new Bosch sensor and installed it. Problem improved but didn't go away completely. And now (after about 100 miles) I lose throttle response about every time I step on it (at about 3000 rpms). Local Volvo shop says it has had issues with Bosch sensors and they only buy from dealers. Dropped it off tonight with local shop to see if they can get to bottom of it. Has anyone had similar experience? I searched archives and didn't see any discussion. thanks.
 

·
Registered
Joined
·
21,166 Posts
Re: Problems with Evolve / Powerchip ECU flash job (LouisvilleSlugger)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>LouisvilleSlugger</b> »</i></TD></TR><TR><TD CLASS="quote">I searched archives and didn't see any discussion. thanks.</TD></TR></TABLE><p>You have learned what many others have............Evolve is a hit/miss vendor. IIRC, Powerchips also solders a piggyback chip which is not a wise idea. Most vendors use an ECU flash which can be reversed when troubleshooting.
 

·
Registered
Joined
·
7,962 Posts
Re: Problems with Evolve / Powerchip ECU flash job (MagoonR)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>MagoonR</b> »</i></TD></TR><TR><TD CLASS="quote"><p>You have learned what many others have............Evolve is a hit/miss vendor. IIRC, Powerchips also solders a piggyback chip which is not a wise idea. Most vendors use an ECU flash which can be reversed when troubleshooting.</TD></TR></TABLE><p>Seems to be a non-Evolve issue. Soldered chips isn't the BEST way to go, but its been done thousands and thousands of times regardless of the car or bran of tune.<p>Sounds like a failure of a sensor or what not, rather than the tune.
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #4 ·
I don't consider it an Evolve issue because Powerchip is its partner in doing the actual upgrade. I don't want to point fingers at anyone, I just want problem diagnosed and solved so that my R will perform as advertised on Evolve website. Hopefully another forum member has already been through this drill and can shed some light. thanks.
 

·
Registered
Joined
·
2,969 Posts
Re: (LouisvilleSlugger)

Next time use a company with a good rep and some positive feedback.Right about now is when the IPD datalogger would come into play and justify the extra $$.... . . <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/sly.gif" BORDER="0">
 

·
Registered
Joined
·
99 Posts
Discussion Starter · #6 ·
Re: (LouisvilleSlugger) (volvosince16)

Does Powerchip have a bad rep? I've seen posts re: Evolve customer service issues and also complaints about fit and finish of various performance parts (like exhaust), but nothing about ECU upgrade.
 

·
Registered
Joined
·
63,543 Posts
Re: (LouisvilleSlugger) (LouisvilleSlugger)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>LouisvilleSlugger</b> »</i></TD></TR><TR><TD CLASS="quote">Does Powerchip have a bad rep? <br></TD></TR></TABLE><p>Oh yeah. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> <br>I talked to the owner years ago, what an a- hole, plus he has serious attitude issues if you blame his programming in any way shape or form.
 

·
Registered
Joined
·
4,248 Posts
Re: (LouisvilleSlugger) (JRL)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JRL</b> »</i></TD></TR><TR><TD CLASS="quote"><p>Oh yeah. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> <br>I talked to the owner years ago, what an a- hole, plus he has serious attitude issues if you blame his programming in any way shape or form.</TD></TR></TABLE><br>WOW!! if JRL sys somes an ass holed brown eye monstre then they RELLLLLY!!! GOT TO BE!!!! WOW!
 

·
Registered
Joined
·
1,057 Posts
Re: (LouisvilleSlugger) (VolvokidS60R)

Theres no CHIP with evolve(powerchip) for the "R" .IT IS A FLASH !!!<<<Just not a consistant one<br>
 
1 - 9 of 9 Posts
Top