SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
Normally when I punch it I'll hit about 10-12 psi then fades to 8 in 3rd at wot. Earlier today I hammered down merging into traffic with no problems, went through the drive through then on my way home I did the same thing only this time it took for ever for boost to climb and stopped at 8 psi. It did this the whole way home. My initial thought is that the wastegate actuator may be stuck open. Engine is still to hot for me to stick my hand in and check. Any theories?

Sent from my SM-N910V using Tapatalk
 

·
Registered
Joined
·
505 Posts
Sounds like the compressor bypass valve. If it is fading off from 10-12psi that badly its leaking. On the 12T (oem turbo) you shouldn't see that type of fade unless you're trying to push over 1 BAR or 14.5psi. At 15psi i never saw fade.

Easy test of the bypass valve is to add a pressure source to the line running to the CBV, at 10psi or so and check for leak down. If it cannot hold pressure, the diaphragm is likely torn or has a pinhole type leak. Use a low pressure pump like a bike pump, or find a cheap blood pressure tester.

Otherwise, another know source of major boost leaks on the 40 series is the IAC hose, it runs from the IAC valve on the throttle body to the intercooler. The hose can become brittle over time and begin leaking up to the point where a total failure will result in poor idle, possibly MAF codes, and no boost.
 

·
Registered
Joined
·
505 Posts
Yes, the ipd kit will fit all the mitsubishi TD04 series turbos. However the mitsubishi original kit is usually cheaper and more effective. Lots of stories of the ipd kit prematurely going out.
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #5 ·
Just an update, car drives fine now and I didn't do anything to fix it. My guess is the tcv may be starting to malfunction, will probably be getting one here soon. Which is nice because I wanted one anyways before I install my mbc, this is just an excuse for my wife lol

Sent from my SM-N910V using Tapatalk
 
1 - 5 of 5 Posts
Top