SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 61 Posts

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #1 · (Edited)
I set timer to precondition every morning in last two winters no problem.
In summer I disabled the timer.
Now I enabled the timer again, first tried through VOC and got error "can't set timer". Looked at it in car and the time was actually enabled.
So this morning at the timed moment, I see "parking climate issue" on VOC, and the car shows message "parking climate unavailable temporarily".

No clue what it means. It is plugged in and fully charged overnight.
Maybe a good chance to get software update. But first want to check if software solution for this exists already.
My software was updated this May.

[Update, I will try track the morning status here.]

12/2 HVCH replaced by dealer. 12/3 got back. 12/4 worked.
11/29 failed
11/28 failed. tried start car but no driving, and set new timer and it worked.
11/27 failed. worked from VoC after a short trip.
11/26 worked from VoC after a short trip.
11/25 failed.
11/23 failed. 39F, worked after a short trip.
11/15-17 failed. 50F
11/14 failed by timer. Start from VoC app and it worked.
11/7-11/8 didn't work.
11/4 It worked but threw the message before it finishes.
10/30 35F worked.
10/29 36F didn't work.

Got software upate in Oct. Problem still persists.
 

·
Registered
Joined
·
116 Posts
I had the similar error. My guess is that parking climate wasn't needed because of no big difference between outside and inside temperature.
 

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #3 ·
I had the similar error. My guess is that parking climate wasn't needed because of no big difference between outside and inside temperature.
Outside is 60F or lower, and I set cabin temperature to 70F. It is not big but still obvious difference.
 

·
Registered
Joined
·
3,830 Posts
I had the issue in Oct. 2018. Here are my notes: “Check out why preconditioning scheduling via VOC does not work on iPhone even though I can start preconditioning manually via the iPhone and VOC.”

I think TJ 33389 might address this. As best I know, I no longer have the issue with the June 17, 2019 update for an XC90.

According to TJ 33389, a software fix should have been included with week 40, 2018 for the XC60s. If nothing else, a TSU now “should” fix it.

I will test mine tomorrow.

Update: I tested my XC90 and the VOC-timed preconditioning worked exactly as expected, on time. I verified that it was working when I went out to the car. In my case, it was 74°F this morning and Climate was set to 74°F.


Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #5 ·
I am trying disable the "use additional heater" option. Will see if any difference. If this works then maybe the high voltage heater is not functioning.

Shoot a report to customer help and they responded saying will get back to me.

Back in May they broke the radiator and replaced it when replacing the thermostat. Could be something forgot to put back together, like a small harness or whatever.

Anyhow, this is probably a chance to get software update. Maybe I could wait till December to get Nov update if any.

Sent from my Z978 using Tapatalk
 

·
Registered
Joined
·
70 Posts
My local dealership tells me there’s no ETA for fixing TJ33389 yet.

I had my XC60 T8 updated about a month ago and it did not include the fix to make parking climate settings work as intended :(
 

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #7 ·
My local dealership tells me there’s no ETA for fixing TJ33389 yet.

I had my XC60 T8 updated about a month ago and it did not include the fix to make parking climate settings work as intended :(
Mine had been working in past winter at least for timed preconditioning. I used it every morning in week days.

Sent from my Z978 using Tapatalk
 

·
Registered
Joined
·
70 Posts
The preconditioning works but all the settings (heated steering wheel and seats) are still ignored by the car.

(I guess it’s a breaking change in the API versions and the 3rd party are that makes the app and Volvocars firmware team probably don’t communicate very well, if at all and are located in very different locations)
 

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #9 ·
The preconditioning works but all the settings (heated steering wheel and seats) are still ignored by the car.

(I guess it’s a breaking change in the API versions and the 3rd party that makes the app and Volvocars firmware team probably don’t communicate very well, if at all)
I had heated seats and steering wheel when preconditioned in morning last winter.

Sent from my Z978 using Tapatalk
 

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #10 · (Edited)
First try, I disabled "use additional heater", start preconditioning from VoC app and it worked as expected.

It failed to stop preconditioning from the app though. So I will wait tomorrow morning and see if the timer works.

Next step will be to enable "using additional heater" and try again. So I can isolate the issue to the high voltage heater.

Sent from my Z978 using Tapatalk
 

·
Registered
Joined
·
3,830 Posts
@FusionRedXC60, sounds like a good plan.

As I updated my post above, preconditioning worked fine, but mine was cooling and dehumidifying - 74°F and 95% humidity with climate set at 72°F in the car.

My additional heater was set to off and heat would not have come on - so my timed preconditioning is not the same scenario as yours.

I will try a heating test later, but it will need to cool down a bit first and it certainly will. I will be taking my car in for swapping out summer tires et al in Oct. and I will request an update if mine is not working. I am optimistic....

Let us know how your test results go.




Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #12 ·
Ok, without additional heater, preconditioning works on timer too.
With additional heater, preconditioning is unavailable on timer, or start from VoC app.
Seems petty clear the high voltage heater is not functioning.

I should have tried this before 20k service. Now need to bring it in again.
 

·
Registered
Joined
·
15 Posts
Ok, without additional heater, preconditioning works on timer too.
With additional heater, preconditioning is unavailable on timer, or start from VoC app.
Seems petty clear the high voltage heater is not functioning.

I should have tried this before 20k service. Now need to bring it in again.
US spec T8, I have somewhat similar issues with preconditioning, seems to be very buggy. I often use "camper mode" for longer road trips to sleep in the car with climate running (wrote a script to keep it running via VoC). Sometimes I get the same error message even when the car is plugged in and charging (unplug the car, start the car, turn off and plug it back in seems to solve the problem for me). Sometimes preconditioning will turn on even when the car is not plugged in, especially when the SoC is high. But yesterday preconditioning still works when the HV battery shows empty @ 0% on both cluster and VoC. Very inconsistent. Car has latest software as of July.
 

·
Registered
Joined
·
1,212 Posts
It’s 39° in my garage this morning so I set a parking climate timer for 9. Turned the heated seats on too. We’ll see what happens.
 

·
Registered
Joined
·
70 Posts
US spec T8, I have somewhat similar issues with preconditioning, seems to be very buggy. I often use "camper mode" for longer road trips to sleep in the car with climate running (wrote a script to keep it running via VoC). Sometimes I get the same error message even when the car is plugged in and charging (unplug the car, start the car, turn off and plug it back in seems to solve the problem for me). Sometimes preconditioning will turn on even when the car is not plugged in, especially when the SoC is high. But yesterday preconditioning still works when the HV battery shows empty @ 0% on both cluster and VoC. Very inconsistent. Car has latest software as of July.
That script sounds interesting. Anything you can share?
I often use the parking climate remote start-AC/heater for my dog when I have to run in to a store or something (I never rely on it of course)
 

·
Registered
Joined
·
7,316 Posts
Discussion Starter · #16 ·
Ok, without additional heater, preconditioning works on timer too.
With additional heater, preconditioning is unavailable on timer, or start from VoC app.
Seems petty clear the high voltage heater is not functioning.

I should have tried this before 20k service. Now need to bring it in again.
This morning it failed again, even without additional heater.
So it is something more involved. Anyhow, service is scheduled a week later. We'll see.
 

·
Registered
Joined
·
1,564 Posts
I am trying disable the "use additional heater" option. Will see if any difference. If this works then maybe the high voltage heater is not functioning.

Shoot a report to customer help and they responded saying will get back to me.

Back in May they broke the radiator and replaced it when replacing the thermostat. Could be something forgot to put back together, like a small harness or whatever.

Anyhow, this is probably a chance to get software update. Maybe I could wait till December to get Nov update if any.

Sent from my Z978 using Tapatalk
Where is this option?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3,830 Posts
Where is this option?


Sent from my iPhone using Tapatalk
In settings on a T8 (e.g., US market)




Sent from my iPhone using Tapatalk Pro
 

·
Registered
Joined
·
1,564 Posts
Ok, without additional heater, preconditioning works on timer too.
With additional heater, preconditioning is unavailable on timer, or start from VoC app.
Seems petty clear the high voltage heater is not functioning.

I should have tried this before 20k service. Now need to bring it in again.
Ok. I’ve got the same problem. I’m at 55k, so this would be why I got the VIP plan I suppose.

I’ve had seasonal Parking climate issues with this car. Happened last year too. And this summer. I feel like they’ve replaced the HV heater system before.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
15 Posts
That script sounds interesting. Anything you can share?
I often use the parking climate remote start-AC/heater for my dog when I have to run in to a store or something (I never rely on it of course)
Sure, there is an open source VoC API by molobrakos on github that can handle pretty much most basic functions of VoC. Link: https://github.com/molobrakos/volvooncall

I just wrote a bash script one night on my phone with a text editor to check some car states and wake up the car every once in a while. Just to give you an idea, nothing fancy and there are many better way to write this script. You should be able to run this on most Linux distro as along as you have the dependencies for VoC API and jq for handling JSON. I would put it on something like a raspberry pi and leave it home and remotely trigger the script either manually or via a secret action (e.g. crack 2 windows open and sunroof for x minuets to toggle the script)

Please do note that none of the code here should be used for experiment purpose only, use at your own risk, you should always have a kill-switch in case something goes haywire. (Like disable everything by changing your VoC password.)

Always use this in a well ventilated area, do not rely on vehicle system to prohibit the engine from starting (Don't assume the ICE won't start if the car is plugged in, T8's J1772 is very badly implemented and sometimes (always) does not appears to be respond to proximity detection pin on the charging connector).

Again, use at your own risk. I am not responsible for what ever happens to you and your car. This is for US spec only, for any other markets the car might behave differently.

#!/bin/bash

#WARNING: FOR TESTING ONLY, VEHICLE SHOULD BE ACTIVELY SUPERVISED AT ALL TIMES, USE AT YOUR OWN RISK.
#infinite loop until script is killed
while :
do

#For logging timestamp
date

#Get HV battery SoC
hv_batt_soc=$(./voc -u <VoC-Username> -p <VoC-Password> -r na print | jq -r ".hvBattery" | jq -r ".hvBatteryLevel")

echo "HV Battery: $hv_batt_soc%"

#Get current climate status
climate_status=$(./voc -u <VoC-Username> -p <VoC-Password> -r na status | grep heater)

echo "$climate_status"

# Proceed w/ camper mode if HV battery SoC is Ok.
if (( "$hv_batt_soc" > 20 )); then

echo "Battery SoC is good, executing camper mode"
# Only invoke RPC to start preconditioning if it's off
# This is only tested w/ USA spec XC60 T8
if [[ $climate_status == *"off"* ]]; then
echo "Climate is off, starting heater"
#Preconditioning state appears to be linked to "heater"
./voc -u <VoC-Username> -p <VoC-Password> -r na heater start | grep heater
else
echo "Climate is on, checking back in 5 mins"
fi

else
# If battery is low the don't preoceed
echo "Battery SoC Low, disabling camper mode"

fi

# Wait 5 mins
sleep 5m

done
 
1 - 20 of 61 Posts
Top