SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
I have a 2006 XC90 with 70K miles on it

The power steering pump has always been a little noisy when it was cold, and we recently had some foaming issues with the fluid.

But now, if I let the car sit for more the 30 minutes, when I start it there is no power steering at all, and as you can imagine it makes a horrendous sound. After about 1 minute the steering comes back, and if I drive it for 5 minutes it is perfect.

I have changed all the fluid, and cleaned out the screen in the reservoir. I have "bleed" the system and we don't seem to be getting any foaming. I have not fully investigated leaks around the rack, but there are no leaks by the reservoir or pump.

Is the pump going bad, or the rack bad?

Thanks
Mark
 

·
Registered
Joined
·
691 Posts
sounds similar to ours before the pump went. Do you have any leaks under the car, ours finally started spewing PS fluid, slowly at first, then pretty bad at end. It is expensive to replace, but worth it afterwards.
 

·
Moderator
Joined
·
3,391 Posts
I too, agree. Replace the power steering pump. I'm going to assume that you've got a 2.5 engine in your car. They are readily available as used, remanufactured, or new. You can pay from $25 to $300+ for a pump. It's all in how much money you'd like to sink into your car. Personally I'm a proponent of low mileage used parts. You can easily find them at www.car-part.com
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
It was the pump. A v8 so a little harder to find re-manufactured so I bought a used pump. Just in time too. The old pump finally blew up and foamed the power-steering fluid almost completely out of the system. Replaced the pump with the low mileage used pump and it is like new.
 

·
Registered
Joined
·
691 Posts
Yep, pretty typical of the V8 PS pump from the posts on here and our experience. Glad you were able to find a low mileage one, we were not so lucky..
 
1 - 5 of 5 Posts
Top