SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #1 ·
Alright Swedespeeders I noticed something fishy last night. In GT mode when I WOT in 3rd from 1.5-2k things seems fine until I hit 3k. Power feels like it stops building or even stumbles a little, simultaneously the rps continue to climb until exactly 3500 at this time the rpms drop to 3000 and climb like it should. Any ideas? Next time I try this I will have a friend sit there and watch the boost pressure and record it. I will provide that tomorrow sometime. Thanks and have a safe weekend all.
 

·
Registered
Joined
·
548 Posts
Erm... I just went through this PITA. You may have similar issue occur soon. Look for a BOOST leak first. If not... Yuck...
http://forums.swedespeed.com/showthread.php?73673-reduced-engine-performance-warning-light

It started week ago Awkward shifts, and almost as if power felt killed at 3k rpms. Then a light appeared, time for regular service.
Ignored. Then R.E.P. warning... Power limited. Car would only transition to next gear at below 3k rpms each time.

Cleaned Throttle Body. Seafoamed the car twice over, including the air filter which was uber dirty until I could get help.
Hired an independent to do the MAF and reset the ECU for $40. Replaced air filter myself. Problem has not returned.


Doing this NOW with detailed MAF/TB cleaning can save you ECU reset. Hurry...
[/QUOTE]
 

·
Registered
Joined
·
1,233 Posts
sorta vague at the moment on this issue, if you can record the rpm drop, and boost separately it may help. also when was the last time you checked the plugs?
 

·
Registered
Joined
·
8,379 Posts
Did You relocate the - TCV to a Cooler Spot ?

Check as there may be some Stored Codes . ( Volvo ) As it might take 2 or 3 times
before - Bing - Code Light .


On the Spark Plugs Gap them Tighter then Spec - Your Coils are getting Old. :beer:
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #5 · (Edited)
Hey guys I'm gonna look at my plugs and TB as I assume neither have been touched. I do have the regular time service light on so I know something is up, what should I use for TB cleaner? I have MAF cleaner in the garage.

Eng- I moved the TCV away from the turbo, I dont pickup any codes from a basic reader but I used my dashboard info button and it came up with these:(cant find my phone cord to upload in images)

DTCS in vehicle:
CEM DTC SET (not sure about this one, maybe when I set my alarm off doing work on the car a month ago)
ECM DTC SET (This guy has me concerned, Engine control module seems kind of important)

The rest were either "checking" or "ready"

Right now I haven't been able to get a hold of a VIDA/DICE unit so I not really sure if I can do anything about the codes until then.
 

·
Registered
Joined
·
2,014 Posts
Did You relocate the - TCV to a Cooler Spot ?

Check as there may be some Stored Codes . ( Volvo ) As it might take 2 or 3 times
before - Bing - Code Light .


On the Spark Plugs Gap them Tighter then Spec - Your Coils are getting Old. :beer:
Dan, none of what you just said (except for obvious - checking the codes) can be related to this guy's problem so stop confusing him unless you have a clear idea what is wrong. And it is obvious you don't.. :D
 

·
Registered
Joined
·
548 Posts
I'll try my best to get video of the problem showing boost pressure and rpm's today but it wont be until I finish working on my buds S4(pads and rotors).
I don't need your stinking Video. I need a picture that you manned up and changed your AIR FILTER.
Use Carb Cleaner or SEAFOAM on the throttle body. It takes a tamper torx 25 to crack that PITA open.

Lastly, if you can bum a ride in an S4 to get new Air Filter do so. You have less than 600 miles before REP Light Appears. It'll take a skilled master tech several attempts at an ECU reset to clear it fully. Greyhound Bus accelerates faster until that R.E.P. Crap gets cleared. Now you know. HURRY.....

Do something. Or VOLVO will.
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #9 · (Edited)
Sorry but you have me a bit confused. For starters you can see my sig below and deduce that I have an aftermarket filter(only in for 2 months.) I plan on cleaning the TB as soon as I can(tomorrow), but what's all this jargon about 600 miles before some catastrophic event occurs that stems from a dirty air filter? I know for a fact that my MAF is clean, filter too. TB could very well be dirty but my service light was reset last night after an oil change which based on the numbers was right on time to come on. I also have new plugs on the way from FCP because im sure they have been in there a while but I don't think I want anyone resetting my ECU since I have it tuned.

**Ahhh REP= Limp mode. I had this happen when I first got the car and did some work on it. Not sure what I did to make it go away but haven't seen it since.
 

·
Registered
Joined
·
548 Posts
I plan on cleaning the TB as soon as I can(tomorrow), but what's all this jargon about 600 miles before some catastrophic event occurs that stems from a dirty air filter?
The Reduced Engine Performance Light... It's Volvo's version of anti-self destruct due to abuse/improper servicing/dirty components.. And keeps it that way until ECU reset by ViDA Nerd...
Did not see your sig, pull the cone off and clean your aftermarket filter that let all the Oil gunk/JUNK onto the MAF in the first place. Then clean MAF. Or Greyhound Bus will out accelerate your car in future.
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #11 ·
I have already cleaned both on MANY occasions over the pas few months while doing mods. My procedures always involve cleaning electrical contacts, sensors, etc. anytime I take them apart. I feel confident that TB and possibly spark is at the bottom of this but I wont know until I try. On the subject of VIDA, this tool is long overdue as a purchase. I take care of 4 Volvo's(family/friends) but have yet to find a good site to purchase it from. Any suggestions? I felt the REP mode and it isn't fun!
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #12 ·
So here's my plan:
-change spark plus
-build leak tester
-triple check hoses associated with the TCV
-detailed clean of throttle body(new seal and electronic clean the throttle sensor plug as well)
-check my fuel pressure sensor as I don't think it has been changed
-clean MAF and KN cone filter just for piece of mind(done this many times this summer

That's all I got and I will be doing those all the same day next week. Anyone think of something I missed that couldn't hurt to try? Thanks SS and wish me luck. I want my third gear power back!
 

·
Registered
Joined
·
837 Posts
What really helped me get rid of that was new ipd coils and a cat
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #15 ·
On the topic of the FPS I took a peak to make sure it wasn't the bad s60 sensors that were up for recall, anyways the serial number checks out so I might skip this in my search for the snake.

Wish USPS would hurry up and deliver my spark.
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #16 ·
Problem is fixed, all I did was change the oil cap seal and change my boost gauge over to a different one. Thoughts? Still planning on doing a good cleaning and plug change.
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #17 ·
Day 1: Spark plugs.
I will let the pictures do that talking, they tell a story from start to finish.
Removing the cover is how it all begin...

Simple Green soak!

I must protect the belt!

Protect the wires!

Oil packs were a mess:
2 Oil soaked and 3 full of sand!


This dont look good either!

Lets do this! + 4 hours

Persistence and hard work pays off!

Getting things back together.

Nice cleaned and blackened cover!


This is the sad part of our story... one of my led's died and this bump happened when I backed out of my garage:

I take blame and my insurance will cover it(RX8) but I have a strict policy that you park on the rocks and not behind garage bays especially when they are in use! So that's where I be at. I will copy this to "what did you do to you car today thread".:rolleyes:
 

·
Registered
Joined
·
4,006 Posts
yikes! why was there oil and sand in the first place?
 

·
Registered
Joined
·
1,695 Posts
Discussion Starter · #19 ·
yikes! why was there oil and sand in the first place?
Oil was from a bad oil cap seal but the sand is anyone guess. Needless to say it was a long cleaning night but I couldn't live with myself knowing that was there.
 

·
Registered
Joined
·
1,023 Posts
I have LOTS of sand in my engine bay. I think it comes in from the gap under the front of the hood and also gets kicked up from the road and into the air scoops that the plastic skid panel under the car has. I can wash my engine and have it packed with sand 4-5 days later
 
1 - 20 of 25 Posts
Top