SwedeSpeed - Volvo Performance Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter · #1 · (Edited)
Hey all haven’t posted in a while ( guess that could be considered a good thing) but I was wondering if anyone could shed some light on a current problem. Currently my car seems to vibrate more than what I think it use to. The vibrations can be felt in the steering wheel slightly if the car is moving or at idle. Its not a violent vibration, and I do not have a check engine light. I was thinking the problem could be from engine mounts or the transmission torque mounts. The car is a 09 c30 r t5 and it has 94000 miles on the clock. I don’t think it is wheels, I just had them balanced and the sway bar and end links look good as well. Also I dont think it could be wheel bearings since the vibrations can be felt wile the car is stationary.

Thanks for any replies.
 

·
Registered
Joined
·
206 Posts
since it at 94k i would check the passenger mount (replacement is around 80-90 on ebay ) also the trans mount but that should be fine however ( e focus mount is around 35-40 direct bolt on ebay) steering wheel is vibrating or shaking check the control arm bushings the rear bushing could have tears ( 140-150 for both entire control arms brand new ebay) hope this helps.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #3 · (Edited)
wow, that’s not too bad, okay ill do that, however just one question are you talking about the front control arms or the actual rear of the cars control arms towards the back hatch and they could cause vibration in the front of the car in the steering wheel.
 

·
Registered
Joined
·
206 Posts
Am talking about the front lower control arms but the rear bushings on them look under your front wheels and turn the steering wheel lock too lock to see if there any tears in the rubber
 

·
Super Moderator
Joined
·
15,179 Posts
since it at 94k i would check the passenger mount (replacement is around 80-90 on ebay ) also the trans mount but that should be fine however ( e focus mount is around 35-40 direct bolt on ebay) steering wheel is vibrating or shaking check the control arm bushings the rear bushing could have tears ( 140-150 for both entire control arms brand new ebay) hope this helps.
Ha! I just posted in the C30 section suggesting control arms as well. Mine are shot at 135k miles of abuse, replacing them this weekend.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #6 ·
haha, thanks again for the post guys. Okay I understand now. Anything else to inspect that could be a possible culprit or anything in general that could lead to a steering wheel vibration at idol and while going down the road?
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #8 ·
thats what I was thinking, just wanted to see if it was something other people have had issues with and what they did. thanks again, alot of help.
 

·
Registered
Joined
·
1,934 Posts
since its both at idle and and driving. Check that right side passenger side mount.
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #10 ·
okay thank you, I was going to check both and see what they do, so just have some one run it through the gears and rev it a tad say 1500 and stand infront of it to see flex anything more than 2" is bad?
 

·
Registered
Joined
·
117 Posts
Discussion Starter · #11 ·
Update: got under the car and looked at the control arm bushings towards the back and looked at both sides looked fine. Got up and looked at the passenger engine mount and it looked okay too, the rubber was black, though I put my finger tips on the rubber could push down on it a bit at the time had the engine running and could feel vibrations, but to me it felt normal. Grabbed some of the pcv lines off the side towards the battery and they were vibrating. I also had someone rev the car up to 2000 and down and up again it honestly felt about the same. The air box on the front was vibrating a good deal too, felt it as well when I had my hands all over the motor. Any other ideas or does it sound like it’s the passenger motor mount causing the issue?

Thank you for all the help.
 
1 - 11 of 11 Posts
Top