SwedeSpeed - Volvo Performance Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
139 Posts
Discussion Starter · #1 ·
So my father's 05 GT has a funky issue. I honestly don't think crap like this happens on any other cars. The dash/speedo console lights up the check engine light whenever you pull up the e-brake - e-brake light still comes on also. It obviously has nothing to do with the actual engine codes. The engine light even stays on when you turn the car off lmao and will stay on as long as as the e-brake is up. Any suggestions aside from replacing the console?
 

·
Registered
Joined
·
1,407 Posts
The DIM (instrument cluster) is the likely cause.
The e brake switch in console is a simple switch and the ebrake light doing as it should tells me it is OK.
A bad ground connection and the connection to the DIM needs to be verified as OK before DIM is replaced.
Most info goes to the cluster via CAN but ebrake switch is direct wired.

It happens on other cars and trucks.
I repaired a Ford Escape with an engine miss. The alternator light blinked in concert with the miss and if it missed badly the gauges all dropped then swept full scale repeatedly.
The bad coil was arcing internally to the power supply wire to that coil. New coil and no more gauge weirdness.
 

·
Registered
Joined
·
139 Posts
Discussion Starter · #3 ·
Any DIY or basic steps on removing the cluster? Also if I were to replace the DIM, I assume I'd need to get it reprogrammed by the dealer.. would it be drivable right after the install? Haha of course Ford would have a similar issue..
 
1 - 3 of 3 Posts
Top