SwedeSpeed - Volvo Performance Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 · (Edited)
About 6 weeks ago I had my rotors replaced due to premature wear . Ever since I got it back from that service call I have a weird clunk / pop sound that comes from the front end. This mostly is noticeable in parking lots and slow speeds like drive thrus , round abouts in my neighborhood etc. I have brought it back to them and the first time they said it was a motor mount that they said they replaced. The noise kept happening so I brought it back . Then they had it for 2 weeks and re-torqued everything associated with the brake job and made sure everything was up to specs and said they could not duplicate the noise . Driving home from dealer it randomly started again and that was about 2 weeks ago . For the past 2 weeks I have tried so nail down what exactly makes the noise happen. It seems it’s when I’m on the brake or just released the brake and also turning the wheel or bringing the wheel back to straight . Now if I put the car in any gear including neutral and step on the brake and turn the wheel it makes the same sound once the wheel is turned far enough to the right or left . Please see the video included to hear the sound. My wife has the same xc90 as I do just a different color and year and hers does not make this sound while doing this . Any suggestions ? Also I forgot to mention coming down a small decline seems to make the noise also. For example leaving a shopping center that has a little dip in the exit onto the main road .


 

·
Registered
Joined
·
170 Posts
there is a lot of friction/resistance from tires when turning wheel when parked.
try to do this without assist, need two hands and body weight to overcome the grip. sounds like strut mount is binding little bit.
put some sand under the tires and try again. if cant here this during driving than forget it.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #3 ·
I 100% hear it while driving , it’s for sure happening while car is moving also mostly at low speeds .


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
81 Posts
I had the exact same noise, started around 25k. After several "can't duplicate" responses, I asked them to replace the sway bar end links on my dime. They told me it was out of alignment, then aligned it, and gave it back to me without any charges. I don't know if they replaced the sway bar end links or not....but now, I have no noise....except for the brakes, which make a lot of noise.
 

·
Registered
Joined
·
413 Posts
About 6 weeks ago I had my rotors replaced due to premature wear . Ever since I got it back from that service call I have a weird clunk / pop sound that comes from the front end. This mostly is noticeable in parking lots and slow speeds like drive thrus , round abouts in my neighborhood etc. I have brought it back to them and the first time they said it was a motor mount that they said they replaced. The noise kept happening so I brought it back . Then they had it for 2 weeks and re-torqued everything associated with the brake job and made sure everything was up to specs and said they could not duplicate the noise . Driving home from dealer it randomly started again and that was about 2 weeks ago . For the past 2 weeks I have tried so nail down what exactly makes the noise happen. It seems it’s when I’m on the brake or just released the brake and also turning the wheel or bringing the wheel back to straight . Now if I put the car in any gear including neutral and step on the brake and turn the wheel it makes the same sound once the wheel is turned far enough to the right or left . Please see the video included to hear the sound. My wife has the same xc90 as I do just a different color and year and hers does not make this sound while doing this . Any suggestions ? Also I forgot to mention coming down a small decline seems to make the noise also. For example leaving a shopping center that has a little dip in the exit onto the main road .


Are you turning the wheel back and forth like that, while stationary??
 

·
Registered
Joined
·
98 Posts
I get the clunk when slowing down and turning left, like into my driveway or a parking spot. I believe it started happening at 10k miles when my rotors were replaced because they were vibrating. Dealer said service bulletin was reason for replacing rotors. Now at 13k miles I have been getting the clunk. Similar to your situation? Anyone else with this issue? Not sure if rotor replacement had anything to do with it, but thought I would give all details.
 

·
Registered
Joined
·
81 Posts
Alignment
 

·
Registered
Joined
·
2,119 Posts
It looks like you took down the video - it isn’t available “this video was removed by the user” so I can’t tell what it’s like compared to clicking sound I’m experiencing. In my case I mentioned it to my service advisor he explained there is a tech journal for addressing clicking/popping sound from the front. We’ve added it to my work order to be addressed for when I go in for the 20k service. If it’s what he thinks it could be related to either air suspension (which would be replaced for the new cartridge kit) or it could be ball joint. I don’t recall if it’s 2 separate or in one journal.
 
1 - 9 of 9 Posts
Top