SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 · (Edited)
PCV Went ... NOT PVC - Motor mount and bracket failed, eff Volvo.

Wow, am I lucky or what?! Roughly 40k miles on the 2006 V50 that I picked up roughly 3 weeks ago. It drove and performed perfectly. Until it didn't. No CEL either. Just a horrific noise and some spattered oil. PCV died.

I was on a short drive from an office supply store home, maybe 2 miles away. I heard a squealing and immediately turned into a parking lot. The car was running for maybe 10 seconds from the first squeal to turning the engine off. Flatbed trailer to the Volvo dealership (Thanks AAA!), but they were already closed for the weekend and won't be open until Monday morning. I dropped off the car in their lot and put my key and night-drop form in the key drop.

I went through all of the PCV threads and I am 99-percent certain that is the issue. I must have blown a few oil seals when the PCV catastrophically failed because there was a small spattering of oil behind the engine on the passenger side.

One of the guys that was first to post on the PCV topic shot video of his squeal and oil spattering and mentioned that the part failed without any warning. Our engine bays look identical. It's crazy how exactly my situation matched his.

This better be covered. Everything better be covered. The Volvo was supposed to be a daily driver. Now I have to drive my weekend toy unless Volvo gives me a loaner.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #3 ·
I just hope they fully address all issues that resulted from the instantaneous death of the PCV. All oil seals, loss of oil, etc. I also noticed that the toothed gears to the right of the engine (that belts are attached to) were putting off some metal shavings. I don't know why that would happen after a PCV failure. It 100% wasn't happening prior. Any ideas?
 

·
Registered
Joined
·
375 Posts
I just hope they fully address all issues that resulted from the instantaneous death of the PCV. All oil seals, loss of oil, etc. I also noticed that the toothed gears to the right of the engine (that belts are attached to) were putting off some metal shavings. I don't know why that would happen after a PCV failure. It 100% wasn't happening prior. Any ideas?
I m surprised the CEL didnt come on first. Almost all the time it does posting a air leakage code, ECM 250 I believe.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #5 ·
Yea. No CEL.

Just got a call from Volvo at 8:11am. They open at 8:30am, so the guys are in early. They said it seems louder than a standard PCV issue, so who knows what is going on. I hope it is the PCV since that's what is covered. I'll get another call this afternoon.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #6 · (Edited)
Starting to think that it might be a timing belt issue. Seizing bearing that has not yet completely frozen? Timing belt going at 40k miles?

I'll post an update as soon as they call me.
 

·
Registered
Joined
·
9,120 Posts
For how quick he shut his car off it's not surprising he didn't get a CEL. He would need to have driven it a few key cycles prior to the ECM-250a fault stores.

It should be covered under the extended warranty. If any damages were incurred from it I would pursue Volvo customer care to have the repairs covered. Especially since you didn't continue driving it as soon as the issue presented itself.
 
1 - 7 of 7 Posts
Top