SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
918 Posts
Discussion Starter · #1 ·
Did a bunch of maint. to the car this week,washed under the hood, plugs, changed every fluid, and filters, and while I had the TB off cleaning it, was gonna pull the PCV banjo bolt to see how bad it looked. Was gonna order the kit from IPD,and have it here, but thought Id have a look see first. Doesn't use a drop of oil, but had a bit of varnish under the fill cap when we got it at 95k(kilometers). We've always used mobil 1 every 7500k, so wondered how much crap would be in it. Suprisingly the TB was not bad really, hadn't been done since 100k, and it now has 215k on it. And the banjo bolt and fitting was SHINY clean. So saved some loot there. Also pulled the fuel rail and stuck a borosope down in injector holes, to see how much carbon buildup there was ........backs of valves are SHINY clean. Put scope down plug holes......very very little carbon. Reason I was looking was can hear a fair bit of pinging(on 91) latly if your on it fairly hard, and boost down a bit. Still same after I was done......ran a bit better, still ping. Was also going to wash rad/intercooler/condensor out, but wanted to do the other stuff first. Pulled fan back out, and grill, and washed them out REAL good,pressure washer from front, hose from back , lots of spray 9 tons of crap and sand came out. .......tons. They use alot of sand/salt up here in winter, so gotta do this every 2 years or so really I think on an intercooled car. Road test again, very little ping, 2 psi more boost almost 8 now. Came back pulled MAF , fair bit of light dust/crap on it.......have never had it out before. Was suprised to see it that dirty, always use OE filters Cleaned it good, road test again. Solid 8psi, pulls hard and smooth. Pulled batt. to reset, and have put 1000k on it this week on vacation, works MUCH better and goes 100k further per tank. Now all I gotta do is 4 wheels brakes and 4 wheel shock/struts!
 

·
Registered
Joined
·
79 Posts
Re: PCV system cleaning, and other interesting ramblings (BellevilleV70)

Awesome!

You say you blew out your intercooler plumbing? Where did you blow into, the back where it slides into the turbo, or the front?

I have a feeling my XC70's suffering form something similar. I'm hearing some pinging now, too, and it's not running as strongly as it used to.

You're lucky to have a boroscope to use. I'd love to be able to use one on my cars.
 

·
Registered
Joined
·
918 Posts
Discussion Starter · #3 ·
Cleaned out the outside, behind the grill, not the plumbing. Crap of the road plugs it up, intercooler doesn't work as well.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top