SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey guys, i've taken on an xc90 project. It's an 03 with the 2.5t and aw55. The truck failed the glove test initially so I changed the oil trap, checked all my hoses to make sure they were clear. Checked the ptc valve but it wasn't clogged at all so i put it back on because it was clear, cleared the block oil passages, cleaned the banjo bolt and fitting where it connects to the IM (it was clogged, but i cleaned it good and check to make sure it worked by blowing in the passages) and still it fails the glove test. At idle it barely inflates the glove, not fully by any means, but you can see there is some tiny amount of pressure there. When i step on it and bring the rpms up, the glove stands up but doesn't blow off or over inflate(i'm testing at the oil cap). I'm at a loss here, where should i start looking?*

- I vacuumed the elbow at the ptc fitting and the glove deflates when the engine is off. so I know that should be working.*
-and I vacuumed the lower oil trap passage and pulled up oil. So i know for sure that's clear.*
-I sprayed all around the vacuum lines and got no change in idle.*
-I did have to change the headgasket 3 weeks ago.*

the truck runs well, and it doesn't use oil and i haven't spotted any leaks so far.

Sent from my Pixel 3 using Tapatalk
 

·
Registered
Joined
·
7 Posts
Sounds like you covered everything with the breather system. Have you done a compression test?
 
1 - 2 of 2 Posts
Top