SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,674 Posts
Discussion Starter · #1 · (Edited)
So I am trying to hunt down why my passenger side window is no longer working. switches appear to be working, I tested the voltage going to the window motor with it unplugged and was getting around 9.5-10v + or - depending on switch up or down, but as soon as I plug the motor in and try i get 0v up or down. I tested the window motor itself and it goes up and down when connected to a battery. Any ideas? I'm thinking a possible ground or the motor is bad/as an internal short somewhere. Where are the grounds for this circuit/circuits?

Does anyone have a diagram of the relay box that's in the cabin buried up under the dash on the drivers side? I cannot find one anywhere.

Second issue. After I tested a few things and tried adding a extra ground wire to the door to see apparently blew a few fuses I replaced all the blown ones I found and now my gas and trunk release no longer work from the driver door, but the release from my remote still works and the fuse seems to be okay. I need to check the relays but have no idea what one is what in the CEU/CEM.
 

·
Registered
Joined
·
1,674 Posts
Discussion Starter · #2 ·
Fixed the gas door and trunk release but still stumped on the pass side window :confused:
 

·
Registered
Joined
·
7,612 Posts
Usually the master switch believe it or not. All the circuits go through there. I've had luck in the past popping the switch out and cleaning the contacts but be careful because sometimes there are little balls and springs and things.

Does it work from the driver door? Does it work with the "all windows down" button? Or does it work from the passenger door?
 

·
Registered
Joined
·
510 Posts
So I am trying to hunt down why my passenger side window is no longer working. switches appear to be working, I tested the voltage going to the window motor with it unplugged and was getting around 9.5-10v + or - depending on switch up or down, but as soon as I plug the motor in and try i get 0v up or down. I tested the window motor itself and it goes up and down when connected to a battery. Any ideas? I'm thinking a possible ground or the motor is bad/as an internal short somewhere. Where are the grounds for this circuit/circuits?

Does anyone have a diagram of the relay box that's in the cabin buried up under the dash on the drivers side? I cannot find one anywhere.

Second issue. After I tested a few things and tried adding a extra ground wire to the door to see apparently blew a few fuses I replaced all the blown ones I found and now my gas and trunk release no longer work from the driver door, but the release from my remote still works and the fuse seems to be okay. I need to check the relays but have no idea what one is what in the CEU/CEM.
Hi - I'm in Toronto and had a C70 previously. I did have an accident on the passenger side of my C70 when I owned it 10 years ago and had it fixed. The cheapest fix was a replacement door from another C70 w/ the window cartridge, however I had the mechanic remove my old cartridge which was working to keep as a spare. You are welcome to it, no charge, just pay for the shipping. If you can arrange for a company to come by, pack it and ship it then its yours. karhas gmail.com
 

·
Registered
Joined
·
1,674 Posts
Discussion Starter · #5 ·
Usually the master switch believe it or not. All the circuits go through there. I've had luck in the past popping the switch out and cleaning the contacts but be careful because sometimes there are little balls and springs and things.

Does it work from the driver door? Does it work with the "all windows down" button? Or does it work from the passenger door?
I can hear the relay when I use the master switch both up and down and have tried cleaning out and such. Unfortunately it does not work from either the passenger door or the all down button. What seems strange is that the motor will work connected to en external battery and when i test the switch with the motor unplugged I get voltage at motor leads, but when i plug it in i get 0.0-0.01v. Unless the motor itself is bad and is grounding out hence it works with the external battery

Hi - I'm in Toronto and had a C70 previously. I did have an accident on the passenger side of my C70 when I owned it 10 years ago and had it fixed. The cheapest fix was a replacement door from another C70 w/ the window cartridge, however I had the mechanic remove my old cartridge which was working to keep as a spare. You are welcome to it, no charge, just pay for the shipping. If you can arrange for a company to come by, pack it and ship it then its yours. karhas gmail.com
Thank you for the offer! Once i do some more troubleshooting i might take you up on that, unless you could just separate the motor from the assembly? would make it easier to ship. :)
 

·
Registered
Joined
·
7,612 Posts
I think you're on the right track with the switch or relay. Symptoms indicate weak current to the door. With no load you see low voltage and with load it just does nothing. So yeah it's either a relay or the master switch, or a bad connection. Motor's fine as you proved.

You could also check the connector at the door pillar and see if there's corrosion or anything.
 
1 - 6 of 6 Posts
Top