SwedeSpeed - Volvo Performance Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I'm wondering if anyone has experienced issues with the passanger seat heat turning off after 4-5 min while passanger is seated ( 180 lbs ) as well as the seat belt light and chime not working while seated, especially when the car is moving and the passanger has unbuckled his belt !?
 

·
Registered
Joined
·
1,732 Posts
You need to go to a dealer asap. Sounds like your passenger seat cannot tell if a person is occupying it. May have implications in a crash where an airbag may not deploy because it thinks the seat is empty.

The heated seat cuts off automatically if it does not believe a person is occupying the seat.
 

·
Registered
Joined
·
1,766 Posts
I'm wondering if anyone has experienced issues with the passanger seat heat turning off after 4-5 min while passanger is seated ( 180 lbs ) as well as the seat belt light and chime not working while seated, especially when the car is moving and the passanger has unbuckled his belt !?
Our passenger seat heater acts inconsistently too. It usually lasts the driving session if turned on, so it's not 4-5 minutes like you. But sometimes it survives to future driving sessions and sometimes it doesn't. The drivers seat stays on between drives. The rear seats turn off on some kind of timer even if its the same driving session so the kids had to keep realizing the seat was cooling and turning them back on. I presume this is by design. But we haven't figured out why the front passenger seats acts different at times.
 

·
Registered
Joined
·
372 Posts
Agreed. There is something wrong with the sensor or even a software glitch. Who knows? But the airbag will not deploy if the car does not sense the passenger correctly.
 

·
Registered
Joined
·
13 Posts
Had same issue
Dealer fixed it when it was in for Nov update

Mine also had habit of switching on when seat was empty��

All seems to work correctly at the moment
 

·
Super Moderator
Joined
·
3,749 Posts
Our passenger seat heater acts inconsistently too. It usually lasts the driving session if turned on, so it's not 4-5 minutes like you. But sometimes it survives to future driving sessions and sometimes it doesn't. The drivers seat stays on between drives. The rear seats turn off on some kind of timer even if its the same driving session so the kids had to keep realizing the seat was cooling and turning them back on. I presume this is by design. But we haven't figured out why the front passenger seats acts different at times.
I don't know what my rear heated seats do but my passenger seat keeps the previous heat setting on for each restart of the car 90% or more of the time. My drivers heated seat (and heated steering wheel) never remembers the setting upon each restart; on each restart it is always off. Kind of annoying it remembers the passenger setting and not the drivers...
 

·
Registered
Joined
·
1,732 Posts
I don't know what my rear heated seats do but my passenger seat keeps the previous heat setting on for each restart of the car 90% or more of the time. My drivers heated seat (and heated steering wheel) never remembers the setting upon each restart; on each restart it is always off. Kind of annoying it remembers the passenger setting and not the drivers...
Are you sure this isn't related to temp? In the morning, when it's cold, heated seat comes on automatically. Afternoon and temp is up, no heated seats. Next morning, back on.
 

·
Registered
Joined
·
1,766 Posts
Are you sure this isn't related to temp? In the morning, when it's cold, heated seat comes on automatically. Afternoon and temp is up, no heated seats. Next morning, back on.
It's not in my case. My car is kept in an attached garage and we've had a record high temp Fall so most mornings it is never cooler than 50 degrees. But regardless of the temp my drivers side has perpetually stayed on for the last 6 weeks between driving sessions. Passenger side is hit-and-miss.
 

·
Registered
Joined
·
1,766 Posts
I don't know what my rear heated seats do but my passenger seat keeps the previous heat setting on for each restart of the car 90% or more of the time. My drivers heated seat (and heated steering wheel) never remembers the setting upon each restart; on each restart it is always off. Kind of annoying it remembers the passenger setting and not the drivers...
Interesting that our perform exactly the opposite of each other. I definitely got the better end of that stick, but yet another odd glitch. I wonder what is supposed to happen? Seems like a lottery so who knows what the intent was.
 

·
Super Moderator
Joined
·
3,749 Posts
Interesting that our perform exactly the opposite of each other. I definitely got the better end of that stick, but yet another odd glitch. I wonder what is supposed to happen? Seems like a lottery so who knows what the intent was.
Yep, the way mine is acting is annoying and further makes no sense why so many peoples XC90's operate different from one another. Absolutely makes no sense quite honestly, especially since we both have First Editions delivered and picked up within 2 days of one another in May.

Out of curiosity, the deal with our cars not having data after the update... Can you connect the vehicle to the wi-fi in your home if parked in the garage, or to a personal hotspot created by a cell phone (if you have a phone that can create a hotspot)?
 

·
Registered
Joined
·
1,766 Posts
Yep, the way mine is acting is annoying and further makes no sense why so many peoples XC90's operate different from one another. Absolutely makes no sense quite honestly.

Out of curiosity, the deal with our cars not having data after the update... Can you connect to the vehicle to wifi in your home if parked in the garage? I had thought we both had the exact same problem concerning data but I can connect mine to external sources like wifi in my home or a hotspot created by a phone, it is ONLY the sim card that doesn't allow for data.
I can't connect on home wi-fi or to a mobile hotspot. If you check to connect it just busy cycles, never presents any option for sources then just comes back to where it was before you licked having done nothing. They couldn't get it to connect to their wifi at the dealership either. Whatever they did completely disabled any Internet connection at all.
 

·
Super Moderator
Joined
·
3,749 Posts
I can't connect on home wi-fi or to a mobile hotspot. If you check to connect it just busy cycles, never presents any option for sources then just comes back to where it was before you licked having done nothing. They couldn't get it to connect to their wifi at the dealership either. Whatever they did completely disabled any Internet connection at all.
Thanks, we are having different issues on that as well then. I had been under the impression ours was exactly the same. I can connect to external wifi at home or the dealership for example and also connect to a hot spot on someone's cell phone, but cannot use the sim card data at all.

If I create a hotspot within the vehicle, I can see it on my cell (Volvo WiFi or whatever it is called) and even connect but when I try surfing using it, it busy cycles.

Strange, strange, strange...
 

·
Registered
Joined
·
1,732 Posts
If I create a hotspot within the vehicle, I can see it on my cell (Volvo WiFi or whatever it is called) and even connect but when I try surfing using it, it busy cycles.
Maybe it's an AT&T issue? Perhaps take the SIM by one of their stores and have them pop it in a phone and see if it connects.
 

·
Super Moderator
Joined
·
3,749 Posts
Maybe it's an AT&T issue? Perhaps take the SIM by one of their stores and have them pop it in a phone and see if it connects.
Trust me on this, if it were only that easy....... I could write more at this point than could fill your screen.
 

·
Registered
Joined
·
1,732 Posts
Trust me on this, if it were only that easy....... I could write more at this point than could fill your screen.
Ha! Please don't.
I do trust the dealer changed SIM's, tried SIM in other vehicle?
 

·
Super Moderator
Joined
·
3,749 Posts

·
Registered
Joined
·
218 Posts
I can't connect on home wi-fi or to a mobile hotspot. If you check to connect it just busy cycles, never presents any option for sources then just comes back to where it was before you licked having done nothing. They couldn't get it to connect to their wifi at the dealership either. Whatever they did completely disabled any Internet connection at all.
So that's EXACTLY the issue I was having after the september update (but before the november update). No internet through any method.

Then after the november update it all started working again (sort of, if i'm using the internal modem it only works for 10 minutes, but tethering and connecting to wifi works).

The dealer didn't do anything to the internet, I think it was just a hard reset on the module that handles the internet. You might have the dealer try that.
 

·
Registered
Joined
·
240 Posts
I'm wondering if anyone has experienced issues with the passanger seat heat turning off after 4-5 min while passanger is seated ( 180 lbs ) as well as the seat belt light and chime not working while seated, especially when the car is moving and the passanger has unbuckled his belt !?
Do you configure the heated seats to automatically turn on at the same time you start the engine? I did this setting to our car and it does turn off 5-10min or so. Maybe that's how it's programmed? If you didn't do it or you manually turned on the heated seats and they turned off by themselves then we might have a problem here, but as far as I'm concern it never happened to me if I got to turn them on myself.

Regarding the seat belt, you're right my wife and my mom would tease me about Volvo's "safety" because twice it happened to us, first my mom then my wife when they were seated on the passenger side. I wasn't aware of it because there's no indicator on the dash nor a sound alerting me that they haven't put on their seat belt, of course they forgot to buckle in as well and they'd only notice it after we've reached our destination.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #19 ·
Joyride , I made sure all automatic funtions were turned off before checking if this happens. Manually turned on the heating. It seems the issue is caused by some sort of sensor probably! Car doesn't always recognize when someone unbuckles , I get the feeling as if vehicle doesn't recognize any passanger sitting at all , going back to the shop on Monday, I'll post some updates then !
 

·
Registered
Joined
·
1 Posts
Joyride , I made sure all automatic funtions were turned off before checking if this happens. Manually turned on the heating. It seems the issue is caused by some sort of sensor probably! Car doesn't always recognize when someone unbuckles , I get the feeling as if vehicle doesn't recognize any passanger sitting at all , going back to the shop on Monday, I'll post some updates then !
Please keep us updated, my passenger seat is acting up.
Comes on only for a few seconds then go's off.

Great forum, thanks for having me.

Regards from the UK.
 
1 - 20 of 21 Posts
Top