SwedeSpeed - Volvo Performance Forum banner
1 - 12 of 12 Posts

·
Premium Member
Joined
·
1,947 Posts
Discussion Starter · #1 ·
Only cel im getting. Haven't seen many threads on this issue. Read in other forums could be a j hose? Originally thought it was the evap purge canister. Don't know. Anyone have this problem?

Thanks for reading.

Matt

Ps Will vida later.


Sent from my SM-G928V using Tapatalk
 

·
Registered
Joined
·
61 Posts
Thanks for sharing!

I have this code as well.. I examined the gas cap and noticed there was an o-ring/seal on the that was visibly dried out/cracked.
I re-lubed the o-ring and flipped it around hoping that would solve the problem, however it worked to no avail.

I will follow this thread and report back on any progress/results from smoke test.
 

·
Registered
Joined
·
6,606 Posts
In VIDA do a gas tank leak test... and make sure the evap value under the intake manifold is plugged in and attached.
 

·
Premium Member
Joined
·
1,947 Posts
Discussion Starter · #6 ·
Wanted to give people an update. After vida and some further research, found out its the leak detection pump. Supposedly there is a rubber diaphragm thats inside the pump that goes bad. In the picture where my hand is, to the right of the evap canister is the pump. Swapping it out tomorrow. Will have more pictures.


Sent from my SM-G928V using Tapatalk
 

·
Premium Member
Joined
·
1,947 Posts
Discussion Starter · #7 ·
Update. Old vs new pics. New one is in and hopefully no more cel from this.


Sent from my SM-G928V using Tapatalk
 

·
Registered
Joined
·
274 Posts
Wanted to give people an update. After vida and some further research, found out its the leak detection pump. Supposedly there is a rubber diaphragm thats inside the pump that goes bad.
Hey Mayor, I'm throwing this same code with a CEL. (Intermittently, tho.) What further t/s led you to the pump? I guess the Vida gas tank leak test? Anything else?
 

·
Premium Member
Joined
·
1,947 Posts
Discussion Starter · #9 ·
Hey Mayor, I'm throwing this same code with a CEL. (Intermittently, tho.) What further t/s led you to the pump? I guess the Vida gas tank leak test? Anything else?
Let me ask this. Do you ever get the gas cap loose message when you just start driving you're car? I didn't do a gas tank leak text. I vida the car after I got the light and the leak detection tank came up in a photo. Before you do anything, I would say buy a new gas cap. See what happens after that.

Sent from my SM-G928V using Tapatalk
 

·
Premium Member
Joined
·
1,947 Posts
Discussion Starter · #10 ·
Finally passed no more cel.


Sent from my SM-G928V using Tapatalk
 

·
Registered
Joined
·
274 Posts
Let me ask this. Do you ever get the gas cap loose message when you just start driving you're car? I didn't do a gas tank leak text. I vida the car after I got the light and the leak detection tank came up in a photo. Before you do anything, I would say buy a new gas cap. See what happens after that.
I haven't gotten that message at all. However, I don't think I replaced the cap after I bought it, so maybe I'll try that first. Thanks.
 

·
Premium Member
Joined
·
1,947 Posts
Discussion Starter · #12 ·
I haven't gotten that message at all. However, I don't think I replaced the cap after I bought it, so maybe I'll try that first. Thanks.
No problem. Good Luck.

Sent from my SM-G928V using Tapatalk
 
1 - 12 of 12 Posts
Top