SwedeSpeed - Volvo Performance Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
Hello everybody,

Its been so long since I last logged in I had to do a password reset access my account.

I need help for an issue that started a couple years ago. My 2006 S60R has had an on and off P0101 CEL and I have 2 master techs both stumped on what it could be(I have searched here too).

I replaced the MAF multiple times and the readings are good based on what they tell me. I can also say they have smoke tested the car with no leaks present as well as changing the crank vent pipe and a valve under the air box(sorry thats all I know). I also had the FPR checked and its output is ok.

The car has 2 characteristics when the CEL is about to turn on or is on. When driving to work I drive a lot of back roads usually in 2nd gear. When my foot is on the throttle a steady 10% and the street is level I feel a slow surging back and forth almost like I am pressing more(15%) and less(5%) on the throttle. The other is when I start the car in the morning there is no rev to 2000k for 10 seconds it starts and then goes right to idle.

The CEL will stay on for 2-5 days and then turn off and then will come back within a week.

Any suggestions would be great!

Thank you
 

·
Super Moderator
Joined
·
8,738 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #4 ·
I have cleaned the filter many times too. I usually also clean out the box when I am washing the car(IPD)

What's your airbox looking like? I think P0101 is low airflow.
 

·
Super Moderator
Joined
·
8,738 Posts
I have cleaned the filter many times too. I usually also clean out the box when I am washing the car(IPD)
If you're saying you have the IPD box....from the post I linked:

"You have the Air Management System (AMS) intake that IPD sold a few years ago (and which Elevate continues to sell). IPD discontinued this product for a good reason, which is that in some cases the AMS setup causes a re-occuring P0101 MAF code."

http://forums.swedespeed.com/showth...-Light-P0101&p=2225314&viewfull=1#post2225314
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #7 ·

·
Registered
Joined
·
4,283 Posts
Good call man. That's gotta be it. From what I've heard it's a roll of the dice as to whether your car will cope with the IPD/Elevate AMS. I've had mine for at least 3 years never an issue. It's unfortunate but you may be forced to switch back. If you do enough research, you will find there is little to no performance advantage to the AMS because the stock box breathes so freely already but it sure does sound and look much nicer.
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #9 ·
I am a little old for the swooshing sound anyway. It was cool in the beginning :)

Reverting back thank you again.

Good call man. That's gotta be it. From what I've heard it's a roll of the dice as to whether your car will cope with the IPD/Elevate AMS. I've had mine for at least 3 years never an issue. It's unfortunate but you may be forced to switch back. If you do enough research, you will find there is little to no performance advantage to the AMS because the stock box breathes so freely already but it sure does sound and look much nicer.
 

·
Registered
Joined
·
4,283 Posts
I am a little old for the swooshing sound anyway. It was cool in the beginning :)

Reverting back thank you again.
Make sure you sell that thing. For the cars it will work on, people will pay good money for that.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top