SwedeSpeed - Volvo Performance Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4,283 Posts
Discussion Starter · #1 ·
So while doing my projector retrofit project, I have ran my battery low on voltage multiple times while trying to level the headlights. Shortly before starting the car to test drive with the new levels, I will notice a "Battery Low Voltage" prompt in my info panel. Car sputters a little but starts on the first try. 5 mintues into the drive I get the P0101 which I read can be due to the MAF not getting proper voltage. Second night of test driving after resetting the code, same thing. Anyone think this is directly related to the battery?

On a side note the battery is OEM Volvo so it is going on 7 years old. I just know these cars can do crazy sh** with a bad battery so I pointed at it as the first culprit.
 

·
Registered
Joined
·
1,411 Posts
Low battery voltage could be a contributor to the problem but MAF being disconnected during the head light project could be a cause.
Relay 2/32 (FMA3) in the engine compartment electrical box is the nest in line if the MAF wasn't disturbed and connector being loose is eliminated.
If the battery went low and that relay chattered for a while that can fail a relay.
 

·
Registered
Joined
·
4,283 Posts
Discussion Starter · #4 ·
I will replace the battery, check the MAF connector, and check the relay then post back on how it all goes.
 

·
Registered
Joined
·
1,411 Posts
How will you check the relay?
Voltage drop between the cable post and green wire (back probe) at injector, MAF, or TCV when the engine is running will tell you if that relay is a problem. any reading over
0.3 V is suspect. If you read the V drop and it is more than that and you tap one decent lick with a screwdriver handle and the V drop goes down (or up, changes) is prrof of bad contacts or broken solder joint.
 
1 - 6 of 6 Posts
Top