SwedeSpeed - Volvo Performance Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I think we all know the amount of problems the ac control modules on these vehicles have. That being said I find mine a bit unique and I've seen similar one's online but none with a solution.

I have a 02 v70, the cintriol module does not the automatic climate controls. Supposedly it's a rare one and maybe even discontinued.

The modules problem Is the throttle speed. When turned all the way off/or all the way full throttle, it'll go haywire and throttle speeds up and down, but any speeds in the middle it'll act normal. Therefore the blower is consistently on. All the other functions work completely normal.

I tried getting it fixed with Xemodex, they couldn't do nothing about it since it shows no fault codes and whatever testing they do in their bench (clearly not connected to a vehicle) didn't show any problems with the unit .

I realize the climate controls have software they come with if you purchase a new one. I was ready to put down almost 800 bucks for a new one. This is my last hope I guess. If anyone can direct me to someone or a way to fix it?

P.s the car has brand new blower, clutch & pulley and charged ac. It'll blow cold at mid throttle speeds all day long. Just want to be able to shut it off.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top