SwedeSpeed - Volvo Performance Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
90 Posts
Discussion Starter · #1 ·
Well after two HID kits for my '05 S60 I was getting fed up with even trying to get a HID kit to work. I just can't stand halogen lights and even the Sylvania Silverstar bulbs are just not the same.

The problem I was having is that either for some reason my S60 would burn out one of the ballasts nearly immediately, or only one headlight would work. Also, I would then get the low beam bulb error message obviously because one light is out.

After reading a lot of praise on this forum for Sharp HID's, I just ordered myself a set of Apexcone/DDM Ultra Slim 55w HID Conversion Kit. I did not order the Low beam error cancellation kit yet, because I'll see if I even need to once I get the kit.

I was getting so frustrated that I've been searching vehemently on eBay for the S60 HID projector headlights with the bi-xenons that our other family S60 has from the factory. But they're nowhere to be found or you can only find one and its damaged. I asked my dealer about ordering the headlights and to have it installed and they said it'd be well above $2k.

So...here we go. Last attempt and hopefully it is with success. I can't wait to get the kit and hopefully you'll see me posting pictures of the kit installed soon!
 

·
Registered
Joined
·
90 Posts
Discussion Starter · #3 ·
Yes, I do have DRL's. I do always keep it on the low beam indicator (so the knob is turned upright), not on the "0" (where the knob would be turned to the left). But whenever I tried going back and forth between the two modes, no difference.

I'm just hoping the SharpHID kit works out; I see alot of people raving about them on here. I saw the one recent thread with the guy complaining but it sounds like there was more of a personality issue than a product issue...
 

·
Registered
Joined
·
17,018 Posts
Re: (Tiny)

Quote, originally posted by Tiny »
Can someone elaborate on why the DRL's won't work properly with HID kits?

your not getting the full 12volts to the ballast and the reason why there shorting out .

The DDRL run at 6volts ? IIRC
 

·
Registered
Joined
·
17,018 Posts
Re: (DGBibo)

I was being grumpy
 

·
Registered
Joined
·
17,018 Posts
Re: (Young Burnsy)

Quote, originally posted by Young Burnsy »


Really? Can you find out if that is true? Seems unlikely to me.

agreed I know its not the full 12v and thats the reason the ballast short out.

could be 10 but again just a guess at what the voltage is , but what I am sure its not the full 12v that you need
 

·
Registered
Joined
·
1,397 Posts
Re: (Young Burnsy)

Quote, originally posted by Young Burnsy »


Really? Can you find out if that is true? Seems unlikely to me.

Its probably PWM and not a reduction in voltage. If you hook up a digital voltmeter to a PWM signal, sometimes things get screwy and you get different voltage readings.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top