SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
Hello all,

I just bought a 2006 XC90 - V8 - about a 135k on the odometer.

I'm figuring more out about the car but absolutely love it so far. Drives very smooth and always power on tap.

When I was driving it home - after 1.5 hours - check engine light came on. I checked the code, was for fuel pressure sensor - high. I reset code and has not come back since. I plan on changing the sensor and fuel filter - believe that should take care of that.

At 3 hours - near the end of my trip - the oil pressure light would flicker on and off. No oil light when driving and accelerating but when I take my foot off the accelerator, it would flicker on for a second and go away.

Did the same thing when I drove it again today.

I've read what I could find on this already but think a lot of the information might go for Volvo 5 cylinders.

  • Owner's manual claims an oil light flicker is normal after hard driving - I dont think I was driving too hard and this shouldnt be normal
  • Bad oil pressure sensor - I believe this to be the culprit and will start here
  • Sludge in the oil pan clogging pickup tube
  • Would deteriorated oil pan pickup o rings apply to this model?
  • Of course actual bad oil pressure could be an issue but engine sounds great and no odd noises.

Anyone else have similar issues with the V8?
 

·
Registered
Joined
·
1,516 Posts
Mine burns oil slightly when I drive it hard, it has 179,000 miles. Is the oil at full? It could just be sloshing around when you take your foot off the pedal, just pushing forward. Not probable, but it's a free first step!
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #3 ·
So I put a quart of oil in it and drove 3 hours round trip. The light would flicker still.

But since I have just been driving it around town - no more than 20 minutes at a time - no light flicker?

I don't think it has been driven very much in a year - oil change sticker is from January. Maybe just needs to wake up and something was sticking in the pan.
 

·
Registered
Joined
·
1,996 Posts
I don't know about the V8s but the oil low sensor in the 3.2 kicks on when I am a qt low. But once it's triggered (even if just sloshed around a corner) the light stays on until the next start up. The flicker to me sounds like an electrical connection loose somewhere.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #5 ·
Thought I'd update this after having driven several thousand miles and having the truck for a while.

I have not seen the oil pressure light flicker in a long while. I've changed the oil with Mobil 1 0W-40 Full SYN probably 2-3 times now - with a new filter each time. The first time I changed it there was some visible sludge in the bottom of the oil filter cap, which I wiped out. The oil now looks pretty good though I'm sure there is probably some sludge in the engine and it was slowing the oil flow.

Also, before the last oil change, the low oil light came on (different from the pressure light) so I may have developed a leak or it burns a little after the switch to full syn. It's a little wet underneath and I fear its from the rear main seal but not enough of a leak for me to worry about it.
 

·
Registered
Joined
·
534 Posts
Is there a place to tap in to find what the pressure actually is or perhaps there is a way with this fancy computer stuff to get a reading?

If that 135k is in miles I think I would go back to the conventional oil. It's just an opinion based on hearsay that engines converted to synthetic later on in mid life will use oil.
 

·
Registered
Joined
·
1,516 Posts
I'm sure Vida has a way to monitor pressure and temperature, it's just hidden somewhere😜 Agreed on the oil remark. I started running Castrol Magnatec 5w-30 and am very happy with it. Almost to the first change with it and am excited to see what shape the oil and filter are in!

Sent From My Igloo Via Polar Bear
 
1 - 7 of 7 Posts
Top