SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi,<br>I dont know what i must check for that. but when i run the car for the 5 min. my oil light open!<br>I have checked my oil gauge for see if oil missing, but all is ok!<br>the oil light open only under 1200rpm and the oil pressure gauge make a null result.<p>A freind told me check the oil pump.. but i dont know where is it!<p>someone have a clue?<p>thanks for helping me!<br>
 

·
Premium Member
Joined
·
19,953 Posts
Re: Oil pressur problem! (volvoid)

Stephane,<p>When the oil light comes on do you hear a loud engine clattering noise?<p>This would mean loss of oil pressure while the engine is running.<p>If you hear this noise shut down immediately.<p>If no loud engine noise then the problem may be with the oil pressure sensor, light and/or gauge.<p>Did this problem happen "all of a sudden" or gradually over time?<p>The oil pump is in the oil pan (sump) and is not accessible without major disassembly.<p>If possible, temporarily replace the existing oil pressure sensor (sender) with a remote oil pressure gauge then start the engine. If the remote gauge shows good oil pressure then the problem is elsewhere.<p><A HREF="http://www.brickboard.com/FAQ/700-900/FAQSummary1.htm" TARGET="_blank">http://www.brickboard.com/FAQ/...1.htm</A><p>George Dill<p>
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Re: Oil pressur problem! (gdill2)

Hi George,<p>You are a good volvo ressources! <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"><p>i hear no noise when the light come on! the light come only when the rpm is less then 1200rpm.<p>for sensor problem! if is that, the light will not be always on?<p>i will replace the sensor for a gauge to see what's append.<p>thanks for helping me!<br>
 
1 - 3 of 3 Posts
Top