SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 48 Posts

·
Registered
Joined
·
363 Posts
Discussion Starter · #1 ·


My first CEL. I suspect my FPS as the car has been randomly stumbling at random times, not specific to engine RPM or load. From reading and some others input here the FPS sounds to be failing. I ordered one from IPD but I am waiting on stock to come in before they can ship.

I had been driving down the back road, and pulled over to let someone pass. When I accelerated away slowly the car stumbled slightly then a few seconds later the CEL came on. Car drove fine the rest of the way. I'm wondering if that stumble caused the engine more grief or if I passed some threshold of sensor failure and it finally lit.

Once I replace the FPS will a cheap code reader be able to clear the CEL? Any recommendations? I don't have a Windows laptop so I'm not in the market for a DICE.

Thanks

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
907 Posts
A cheap code reader can, yeah. When I'm out and about and don't have DICE/my laptop handy, I use a bluetooth OBD2 dongle and the Torque app to read/clear basic codes.
 

·
Registered
Joined
·
2,621 Posts
Sounds more like a misfire. I would highly suggest not diagnosing by reading the internet and ordering parts BEFORE you even have a fault read. Your issue can be a multitude of different failures and proper diagnosis will save you time and money.
 

·
Registered
Joined
·
363 Posts
Discussion Starter · #5 ·
I ordered the part BEFORE I had any fault codes because the stumbling never caused a CEL. I was attempting to address an issue the car had which apparently wasn't significant enough to cause a CEL. "Luckily" for me the CEL finally showed its face tonight.

And I inquired about a code reader to both read and clear the code, assume it seems consistent with everything else I have read on these failing FPS. I also ordered spark plugs (amongst other things) to do a minor "tune up" as I just purchased the car a few months ago.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
438 Posts
Get vida. Truly join the club


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6,608 Posts
Yep. VMware is what I use... Why waste my precious SSD space on a full windoze partition.
 

·
Registered
Joined
·
438 Posts
Yeah. VMware fusion should work


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
80 Posts
sounds like when I had same problem. there were several threads about where to get one...seems like I ordered it somewhere other than ipd, but not sure. anyway, followed the writeup here on changing the part and had no problems.
 

·
Registered
Joined
·
2,621 Posts
Ya I need to find a cheap Windows laptop solution. Don't own one. Might do bootcamp to make it work with my MacBook.
A cheap Dell D630 or D630 ATG is what I've always used. Can get them on ebay for $50. Add a cheap SSD and VIDA loads and run fast.
I got my ATG for $70, run a 120GB SSD with Win7 and 2GB ram. Have to modify the ini files to install on less than 4gb RAM but runs just fine. There are some guides somewhere on here on how to do that. The Dice can be bought for about $120. A Pro Setup for about $200
 

·
Registered
Joined
·
434 Posts
I have a MacBook Pro. Do not bother with using VMWare, you have to pay for it! Use Virtual Box instead, it's open source and works great with VIDA! I used to have Boot Camp but did away with it and run an SSD now. I use XP Pro for VIDA. No complaints and it's free!
 

·
Registered
Joined
·
8,062 Posts
HA! I thought this thread was about joining the cracked cylinder club. Glad to hear it's not

Yeah no excuses just install vida on a VM. it's the only way to go. It'll pay for itself in one usage. The ROI w/ VIDA + the R so high you'll fkn jizz then poop your pants. it *will* melt your brain and liquefy your organs from joy. I owned an SR MT for 5 years as my total commuter car before the VR and I used to ask the dealer and/ or indy mechanics what is up when some message or DTC would pop up and this was a waste of time... kinda like asking the internet to help diagnose a check engine light.

Also guessing fps or coils may seem likely but it's best not to spend $$ on parts. I also replaced fps a few yrs ago and it was perfectly fine. Also replaced other parts over the years guessing it would fix shyte. Just no.

In fact last month thanks to ViDA telling me -and the ridiculous volume of info written about it- my last dtc DEM007 was just the DEM temp sensor. It literally tells you what/where the failed part is and how to fix it. About 100 bucks later, BA BAM!! Vida paid for itself again/ DTC 100% cleared, fixed. now happy back to rear wheel burners on gravel and accelerating sideways at 90mph on hwy 280 running from the chp and their shiddy new ford explorers
^This, it makes any diagnosis so much easier since you can watch any sensor value or control parameter in the car and provides a lot of particular tests as well. Best investment you can make when you have an R, wish I had bought mine years earlier.
 

·
Registered
Joined
·
6,608 Posts
I have a MacBook Pro. Do not bother with using VMWare, you have to pay for it! Use Virtual Box instead, it's open source and works great with VIDA! I used to have Boot Camp but did away with it and run an SSD now. I use XP Pro for VIDA. No complaints and it's free!
Virtual box doesn't support USB3 pass through in a lot of cases. I tried. I'm assuming your MBP had an HDD?
 

·
Registered
Joined
·
434 Posts
Virtual box doesn't support USB3 pass through in a lot of cases. I tried. I'm assuming your MBP had an HDD?
It used to, which I replaced with a 500GB SSD. My MBP is from 2011 or 2012 so it's oldish. Are you saying the new Pros have only USB 3.0?
 

·
Registered
Joined
·
8,062 Posts
Virtual box doesn't support USB3 pass through in a lot of cases. I tried. I'm assuming your MBP had an HDD?
I had the same issue, though I assume not everyone else would since lots of things like this can be very hardware/driver/OS specific.
 

·
Registered
Joined
·
2,045 Posts
I used vmware so that I could use vida on Windows 8.1. Works great. Would save ya from having to get another laptop

From my electronic gismo- Galaxy S6
 

·
Registered
Joined
·
6,608 Posts
It used to, which I replaced with a 500GB SSD. My MBP is from 2011 or 2012 so it's oldish. Are you saying the new Pros have only USB 3.0?
Yep. Both ports are USB3... I looked for a workaround but couldn't find one. Perhaps there is a thunderbolt to usb adaptor that's USB2
 

·
Registered
Joined
·
434 Posts
Yep. Both ports are USB3... I looked for a workaround but couldn't find one. Perhaps there is a thunderbolt to usb adaptor that's USB2
I'm kind of an open source guy, and hate paying for software. I use Gimp instead of Photoshop, Inkscape instead of Illustrator, Brackets instead of Dreamweaver or whatever else. If VMWare works well awesome but since VirtualBox works for me I'll stick with using that. Haven't checked but it seems like they would have some bug fix or patch or something which would allow for USB 3.0 duty.

Actually I started using VIDA in Bootcamp in XP-Mode on Windows 7 Home which required a hack. After I found out that I didn't need to use Windows 7 anymore, I converted the XP VM to work in VirtualBox and got rid of my Window 7 partition. Now I just use the VM installed directly on the Mac.
 
1 - 20 of 48 Posts
Top