SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2009 XC90 R design with 1060 miles on it... as of tomorrow I will have owned it for 30 days and it has been in the repair shop for 7 of those well 8 counting tomorrow. It has been having a reduced engine performance message and then it drains the battery for no reason and struggles to start then only goes 5 mph engine revving the whole time. I am not sure where to go from here but this should NOT happen to a car this new...any suggestions? <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0">
 

·
Registered
Joined
·
2,118 Posts
Re: Offically Frustrated 2009 XC90 (vduffer)

3.2 or V8? Sounds like a bad alternator or battery. I trust that your dealership is handling the problem? 8 days is a long time, have they updated you on their progress?
 

·
Registered
Joined
·
827 Posts
Re: Offically Frustrated 2009 XC90 (Cabot)

<p>Start talking lemon law....
 

·
Registered
Joined
·
1,909 Posts
Re: Offically Frustrated 2009 XC90 (dmd)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>dmd</b> »</i></TD></TR><TR><TD CLASS="quote"><p>Start talking lemon law....</TD></TR></TABLE><p>This! I would start seeing what else they have on the lot.
 

·
Registered
Joined
·
1,909 Posts
Re: Offically Frustrated 2009 XC90 (Husker Z)

Any update on what you did? Just curious.
 
1 - 5 of 5 Posts
Top