SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey guys! Last week I was in garage with my v50 d2 2011 and now I've got a few issues. Mechaniker mad a basic yearly maintance (new oil/filter/pollen filter/airfilter/etc). After a few km I've got a yellow failure code. The garage tried to read out the failure code and the obd wasn't got Current. I've tried to read out with my vida dice, but I also Won't have any current in my obd port. I've read from the display the failure code and it was 018 (Oil was a few dl too much). Now I can't use my OBD...won't work. After a few km i realized that my cruise control also won't work. I already checked down the fuses and everithing is fine with them. Can somebody have any idea what i can do with my OBD and my cruise controll? That garage used to be..... :(
 

·
Registered
Joined
·
276 Posts
I might be able to help with the OBD issue. Check the connectors to the CEM under the glove box. When I first purchased my car the OBD port didn't work and I traced it back to an individual wire that had pushed out of its connector. There are several videos online about removing and cleaning the connectors to the CEM and these should be useful to you.

For cruise control - do you have a manual or automatic transmission? I have a manual and occasionally get a code indicating the clutch position sensor is malfunctioning and this can affect the cruise control. Once you get the OBD port working Vida/Dice should help you sort that out.
 
1 - 2 of 2 Posts
Top